f79d29c405ac886cc2c41838670cf83491fbd004
[mesa.git] / docs / MESA_resize_buffers.spec
1 Name
2
3 MESA_resize_buffers
4
5 Name Strings
6
7 GL_MESA_resize_buffers
8
9 Contact
10
11 Brian Paul (brian.paul 'at' tungstengraphics.com)
12
13 Status
14
15 Shipping (since Mesa version 2.2)
16
17 Version
18
19 $Id: MESA_resize_buffers.spec,v 1.3 2004/03/25 01:42:42 brianp Exp $
20
21 Number
22
23 196
24
25 Dependencies
26
27 Mesa 2.2 or later is required.
28
29 Overview
30
31 Mesa is often used as a client library with no integration with
32 the computer's window system (an X server, for example). And since
33 Mesa does not have an event loop nor window system callbacks, it
34 cannot properly respond to window system events. In particular,
35 Mesa cannot automatically detect when a window has been resized.
36
37 Mesa's glViewport command queries the current window size and updates
38 its internal data structors accordingly. This normally works fine
39 since most applications call glViewport in responce to window size
40 changes.
41
42 In some situations, however, the application may not call glViewport
43 when a window size changes but would still like Mesa to adjust to
44 the new window size. This extension exports a new function to solve
45 this problem.
46
47 New Procedures and Functions
48
49 void glResizeBuffersMESA( void )
50
51 New Tokens
52
53 none
54
55 Additions to the OpenGL Specification (no particular section)
56
57 The glResizeBuffersMESA command may be called when the client
58 determines that a window has been resized. Calling
59 glResizeBuffersMESA causes Mesa to query the current window size
60 and adjust its internal data structures. This may include
61 reallocating depth, stencil, alpha and accumulation buffers.
62
63 Additions to the AGL/GLX/WGL Specifications
64
65 None
66
67 Errors
68
69 INVALID_OPERATION is generated if ResizeBuffersMESA is called betweeen
70 Begin and End.
71
72 New State
73
74 None.
75
76 New Implementation Dependent State
77
78 None.
79
80 Revision History
81
82 * Revision 1.0 - Initial specification