First draft.
[mesa.git] / docs / MESA_shader_debug.spec
1 Name
2
3 MESA_shader_debug
4
5 Name Strings
6
7 GL_MESA_shader_debug
8
9 Contact
10
11 Brian Paul (brian.paul 'at' tungstengraphics.com)
12 Michal Krol (mjkrol 'at' gmail.com)
13
14 Status
15
16 XXX - Not complete yet!!!
17
18 Version
19
20 Last Modified Date: May 29, 2006
21 Author Revision: 0.1
22 $Date: 2006/05/30 09:35:36 $ $Revision: 1.1 $
23
24 Number
25
26 TBD
27
28 Dependencies
29
30 OpenGL 1.5 is required.
31 The extension is written against the OpenGL 1.5 specification.
32 ARB_shading_language_100 is required.
33 ARB_shader_objects is required.
34 The extension is written against the OpenGL Shading Language
35 1.10 Specification.
36
37 Overview
38
39 TBD
40
41 IP Status
42
43 None
44
45 Issues
46
47 None
48
49 New Procedures and Functions
50
51 TBD
52
53 New Types
54
55 None
56
57 New Tokens
58
59 TBD
60
61 Additions to Chapter 2 of the OpenGL 1.5 Specification
62 (OpenGL Operation)
63
64 None
65
66 Additions to Chapter 3 of the OpenGL 1.5 Specification (Rasterization)
67
68 None
69
70 Additions to Chapter 4 of the OpenGL 1.5 Specification (Per-Fragment
71 Operations and the Frame Buffer)
72
73 None
74
75 Additions to Chapter 5 of the OpenGL 1.5 Specification
76 (Special Functions)
77
78 None
79
80 Additions to Chapter 6 of the OpenGL 1.5 Specification (State and State
81 Requests)
82
83 None
84
85 Additions to Appendix A of the OpenGL 1.5 Specification (Invariance)
86
87 None
88
89 Additions to Chapter 1 of the OpenGL Shading Language 1.10 Specification
90 (Introduction)
91
92 None
93
94 Additions to Chapter 2 of the OpenGL Shading Language 1.10 Specification
95 (Overview of OpenGL Shading)
96
97 None
98
99 Additions to Chapter 3 of the OpenGL Shading Language 1.10 Specification
100 (Basics)
101
102 None
103
104 Additions to Chapter 4 of the OpenGL Shading Language 1.10 Specification
105 (Variables and Types)
106
107 None
108
109 Additions to Chapter 5 of the OpenGL Shading Language 1.10 Specification
110 (Operators and Expressions)
111
112 None
113
114 Additions to Chapter 6 of the OpenGL Shading Language 1.10 Specification
115 (Statements and Structure)
116
117 None
118
119 Additions to Chapter 7 of the OpenGL Shading Language 1.10 Specification
120 (Built-in Variables)
121
122 None
123
124 Additions to Chapter 8 of the OpenGL Shading Language 1.10 Specification
125 (Built-in Functions)
126
127 Add a new section 8.10 "Debug Functions":
128
129 Debug functions are available to both fragment and vertex shaders.
130 They are used to track the execution of a shader by logging
131 passed-in arguments to the shader's info log. That values can be
132 retrieved and validated by the application after shader execution
133 is complete.
134
135 void printMESA(const float value);
136 void printMESA(const int value);
137 void printMESA(const bool value);
138 void printMESA(const vec2 value);
139 void printMESA(const vec3 value);
140 void printMESA(const vec4 value);
141 void printMESA(const ivec2 value);
142 void printMESA(const ivec3 value);
143 void printMESA(const ivec4 value);
144 void printMESA(const bvec2 value);
145 void printMESA(const bvec3 value);
146 void printMESA(const bvec4 value);
147 void printMESA(const mat2 value);
148 void printMESA(const mat3 value);
149 void printMESA(const mat4 value);
150 void printMESA(const sampler1D value);
151 void printMESA(const sampler2D value);
152 void printMESA(const sampler3D value);
153 void printMESA(const samplerCube value);
154 void printMESA(const sampler1DShadow value);
155 void printMESA(const sampler2DShadow value);
156
157 Additions to Chapter 9 of the OpenGL Shading Language 1.10 Specification
158 (Shading Language Grammar)
159
160 None
161
162 Additions to Chapter 10 of the OpenGL Shading Language 1.10
163 Specification (Issues)
164
165 None
166
167 Additions to the AGL/EGL/GLX/WGL Specifications
168
169 None
170
171 GLX Protocol
172
173 None
174
175 Errors
176
177 TBD
178
179 New State
180
181 TBD
182
183 New Implementation Dependent State
184
185 TBD
186
187 Sample Code
188
189 TBD
190
191 Revision History
192
193 29 May 2006
194 Initial draft. (Michal Krol)