drm-shim: Let the driver choose to overwrite the first render node.
[mesa.git] / docs / specs / OLD / MESA_agp_offset.spec
1 Name
2
3 MESA_agp_offset
4
5 Name Strings
6
7 GLX_MESA_agp_offset
8
9 Contact
10
11 Brian Paul, Tungsten Graphics, Inc. (brian.paul 'at' tungstengraphics.com)
12 Keith Whitwell, Tungsten Graphics, Inc. (keith 'at' tungstengraphics.com)
13
14 Status
15
16 Obsolete. Effectively superseded by ARB_vertex_buffer_object.
17
18 Version
19
20 1.0
21
22 Number
23
24 TBD
25
26 Dependencies
27
28 OpenGL 1.0 or later is required
29 GLX_NV_vertex_array_range is required.
30 This extensions is written against the OpenGL 1.4 Specification.
31
32 Overview
33
34 This extensions provides a way to convert pointers in an AGP memory
35 region into byte offsets into the AGP aperture.
36 Note, this extension depends on GLX_NV_vertex_array_range, for which
37 no real specification exists. See GL_NV_vertex_array_range for more
38 information.
39
40 IP Status
41
42 None
43
44 Issues
45
46 None
47
48 New Procedures and Functions
49
50 unsigned int glXGetAGPOffsetMESA( const void *pointer )
51
52 New Tokens
53
54 None
55
56 Additions to the OpenGL 1.4 Specification
57
58 None
59
60 Additions to Chapter 3 the GLX 1.4 Specification (Functions and Errors)
61
62 Add a new section, 3.6 as follows:
63
64 3.6 AGP Memory Access
65
66 On "PC" computers, AGP memory can be allocated with glXAllocateMemoryNV
67 and freed with glXFreeMemoryNV. Sometimes it's useful to know where a
68 block of AGP memory is located with respect to the start of the AGP
69 aperture. The function
70
71 GLuint glXGetAGPOffsetMESA( const GLvoid *pointer )
72
73 Returns the offset of the given memory block from the start of AGP
74 memory in basic machine units (i.e. bytes). If pointer is invalid
75 the value ~0 will be returned.
76
77 GLX Protocol
78
79 None. This is a client side-only extension.
80
81 Errors
82
83 glXGetAGPOffsetMESA will return ~0 if the pointer does not point to
84 an AGP memory region.
85
86 New State
87
88 None
89
90 Revision History
91
92 20 September 2002 - Initial draft
93 2 October 2002 - finished GLX chapter 3 additions
94 27 July 2004 - use unsigned int instead of GLuint, void instead of GLvoid