radeon: fix glCopyTex(Sub)Image if user FBO is bound
[mesa.git] / docs / MESA_copy_sub_buffer.spec
index 6402a5ff425ce2dd8c2828d92a4f315490f97f9d..752a014b352e8d27d34fa3d04aa8607fdbc69d7d 100644 (file)
@@ -8,7 +8,7 @@ Name Strings
 
 Contact
 
-    Brian Paul (brian 'at' mesa3d.org)
+    Brian Paul (brian.paul 'at' tungstengraphics.com)
 
 Status
 
@@ -16,11 +16,11 @@ Status
 
 Version
 
-    Last Modified Date:  8 June 2000
+    Last Modified Date:  12 January 2009
 
 Number
 
-    ???
+    215
 
 Dependencies
 
@@ -45,7 +45,7 @@ Issues
 New Procedures and Functions
 
     void glXCopySubBufferMESA( Display *dpy, GLXDrawable drawable,
-                               int x, int y, int width, int height );
+                              int x, int y, int width, int height );
 
 New Tokens
 
@@ -57,8 +57,8 @@ Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors)
 
     The function
 
-         void glXCopySubBufferMESA( Display *dpy, GLXDrawable drawable,
-                                    int x, int y, int width, int height );
+        void glXCopySubBufferMESA( Display *dpy, GLXDrawable drawable,
+                                   int x, int y, int width, int height );
 
     may be used to copy a rectangular region of the back color buffer to
     the front color buffer.  This can be used to quickly repaint 3D windows
@@ -68,7 +68,13 @@ Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors)
     <x> and <y> indicates the lower-left corner of the region to copy and
     <width> and <height> indicate the size in pixels.  Coordinate (0,0)
     corresponds to the lower-left pixel of the window, like glReadPixels.
-    
+
+    If dpy and drawable are the display and drawable for the calling
+    thread's current context, glXCopySubBufferMESA performs an
+    implicit glFlush before it returns.  Subsequent OpenGL commands
+    may be issued immediately after calling glXCopySubBufferMESA, but
+    are not executed until the copy is completed. 
+
 GLX Protocol
 
     None at this time.  The extension is implemented in terms of ordinary
@@ -84,5 +90,7 @@ New State
 
 Revision History
 
-    8 June 2000 - initial specification
+    12 January 2009 Ian Romanick - Added language about implicit flush
+                                   and command completion.
+    8 June 2000     Brian Paul   - initial specification