docs: update GL3.txt status
[mesa.git] / docs / MESA_swap_control.spec
index e05d515496f943b3be55fbb2b5f837a890239beb..856978b535b7ca6b7f8b2e1e2ab3d4bcc42cdf81 100644 (file)
@@ -8,7 +8,7 @@ Name Strings
 
 Contact
 
-    Ian Romanick, IBM  (idr 'at' us.ibm.com)
+    Ian Romanick, IBM, idr at us.ibm.com
 
 Status
 
@@ -16,7 +16,7 @@ Status
 
 Version
 
-    Date: 3/17/2003   Revision: 1.0
+    Date: 5/1/2003   Revision: 1.1
 
 Number
 
@@ -34,9 +34,16 @@ Overview
     This extension allows an application to specify a minimum periodicity
     of color buffer swaps, measured in video frame periods.
 
+Issues
+
+    * Should implementations that export GLX_MESA_swap_control also export
+      GL_EXT_swap_control for compatibility with WGL_EXT_swap_control?
+
+    UNRESOLVED.
+
 New Procedures and Functions
 
-    int glXSwapIntervalMESA(int interval)
+    int glXSwapIntervalMESA(unsigned int interval)
     int glXGetSwapIntervalMESA(void)
 
 New Tokens
@@ -89,18 +96,15 @@ Additions to the GLX 1.3 Specification
     The swap interval is not part of the render context state.  It cannot
     be pushed or popped.  The current swap interval for the window
     associated with the current context can be obtained by calling
-    glXGetSwapIntervalMESA.  The default swap interval is 1.
+    glXGetSwapIntervalMESA.  The default swap interval is 0.
 
-    On XFree86, setting the environment variable LIBGL_NO_VSYNC sets the
-    swap interval to 0.
+    On XFree86, setting the environment variable LIBGL_THROTTLE_REFRESH sets
+    the swap interval to 1.
 
 Errors
 
-    glXSwapIntervalMESA returns GLX_BAD_VALUE if parameter <interval> is
-    less than zero.
-
     glXSwapIntervalMESA returns GLX_BAD_CONTEXT if there is no current
-    GLXContext.
+    GLXContext or if the current context is not a direct rendering context.
 
 GLX Protocol
 
@@ -110,8 +114,16 @@ New State
 
     Get Value          Get Command     Type        Initial Value
     ---------          -----------     ----        -------------
-    [swap interval]    GetSwapInterval Z+          1
+    [swap interval]    GetSwapInterval Z+          0
 
 New Implementation Dependent State
 
     None
+
+
+Revision History
+
+    1.1,  5/1/03   Added the issues section and contact information.
+                  Changed the default swap interval to 0.
+    1.0,  3/17/03  Initial version based on GLX_SGI_swap_control and
+                   WGL_EXT_swap_control.