docs: update GL3.txt status
[mesa.git] / docs / MESA_swap_control.spec
index ecc674649e2ad149cf29bbc93d851065e0b522e2..856978b535b7ca6b7f8b2e1e2ab3d4bcc42cdf81 100644 (file)
@@ -43,7 +43,7 @@ Issues
 
 New Procedures and Functions
 
-    int glXSwapIntervalMESA(int interval)
+    int glXSwapIntervalMESA(unsigned int interval)
     int glXGetSwapIntervalMESA(void)
 
 New Tokens
@@ -103,11 +103,8 @@ Additions to the GLX 1.3 Specification
 
 Errors
 
-    glXSwapIntervalMESA returns GLX_BAD_VALUE if parameter <interval> is
-    less than zero.
-
     glXSwapIntervalMESA returns GLX_BAD_CONTEXT if there is no current
-    GLXContext.
+    GLXContext or if the current context is not a direct rendering context.
 
 GLX Protocol