bin/get-pick-list.sh: handle the fixes tag
[mesa.git] / docs / specs / WL_bind_wayland_display.spec
index 4057b4e4bece13eab2f5c30d5d8f26fccc0ebcc8..785489088a0e272aa5dc6f3f6ba5485bedf58702 100644 (file)
@@ -75,6 +75,7 @@ New Tokens
         EGL_TEXTURE_Y_U_V_WL                    0x31D7
         EGL_TEXTURE_Y_UV_WL                     0x31D8
         EGL_TEXTURE_Y_XUXV_WL                   0x31D9
+        EGL_TEXTURE_EXTERNAL_WL                 0x31DA
 
     Accepted in the <attribute> parameter of eglQueryWaylandBufferWL:
 
@@ -148,6 +149,10 @@ Additions to the EGL 1.4 Specification:
                 Two planes, samples Y from the first plane to r in
                 the shader, U and V from the second plane to g and a.
 
+        EGL_TEXTURE_EXTERNAL_WL
+                Treated as a single plane texture, but sampled with
+                samplerExternalOES according to OES_EGL_image_external
+
     After querying the wl_buffer layout, create EGLImages for the
     planes by calling eglCreateImageKHR with wl_buffer as
     EGLClientBuffer, EGL_WAYLAND_BUFFER_WL as the target, NULL