mcelog: new package
authorRomain Naour <romain.naour@openwide.fr>
Fri, 21 Nov 2014 20:59:06 +0000 (21:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Nov 2014 17:43:01 +0000 (18:43 +0100)
[Thomas:
  - use "make install", which allows to remove the custom installation
    logic in mcelog.mk.
  - no need to explicitly pass CFLAGS and CPPFLAGS when doing the
    build, since those definitions are already part of
    $(TARGET_CONFIGURE_OPTS).]

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/mcelog/Config.in [new file with mode: 0644]
package/mcelog/mcelog.mk [new file with mode: 0644]

index e91e95b16c24a80b732ddd43c956629b635dc542..9188041e0452e94fef5529012ba5e99c0dc3137a 100644 (file)
@@ -76,6 +76,7 @@ endif
        source "package/lttng-babeltrace/Config.in"
        source "package/lttng-modules/Config.in"
        source "package/lttng-tools/Config.in"
+       source "package/mcelog/Config.in"
        source "package/memstat/Config.in"
        source "package/netperf/Config.in"
        source "package/oprofile/Config.in"
diff --git a/package/mcelog/Config.in b/package/mcelog/Config.in
new file mode 100644 (file)
index 0000000..f3ccc71
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_MCELOG
+       bool "mcelog"
+       depends on BR2_i386 || BR2_x86_64
+       depends on BR2_USE_MMU # fork()
+       help
+         mcelog processes machine checks (in particular memory and CPU hardware
+         errors) on modern x86 Linux systems.
+
+         http://www.mcelog.org/
diff --git a/package/mcelog/mcelog.mk b/package/mcelog/mcelog.mk
new file mode 100644 (file)
index 0000000..da338ba
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# mcelog
+#
+################################################################################
+
+MCELOG_VERSION = v105
+MCELOG_SITE = $(BR2_KERNEL_MIRROR)/scm/utils/cpu/mce/mcelog.git
+MCELOG_SITE_METHOD = git
+MCELOG_LICENSE = GPLv2
+MCELOG_LICENSE_FILES = README
+
+define MCELOG_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define MCELOG_INSTALL_TARGET_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
+
+$(eval $(generic-package))