package/libodb-boost: new package
authorKamel Bouhara <kamel.bouhara@bootlin.com>
Mon, 6 Jul 2020 15:30:40 +0000 (17:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jul 2020 13:42:04 +0000 (15:42 +0200)
This package contains the Boost ODB profile library. The Boost profile
provides support for persisting Boost smart pointers, containers, and
value types with the ODB system.

Signed-off-by: Kamel Bouhara <kamel.bouhara@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/libodb-boost/Config.in [new file with mode: 0644]
package/libodb-boost/libodb-boost.hash [new file with mode: 0644]
package/libodb-boost/libodb-boost.mk [new file with mode: 0644]

index c615ee35004918d6565880d27790bc4275dcfb49..203c4546aff4d90edac30806d83eecc58cdbb64d 100644 (file)
@@ -1435,6 +1435,7 @@ N:        Justin Maggard <jmaggard@netgear.com>
 F:     package/dtach/
 
 N:     Kamel Bouhara <kamel.bouhara@gmail.com>
+F:     package/libodb-boost/
 F:     package/libodb-mysql/
 
 N:     Karoly Kasza <kaszak@gmail.com>
index e845d1c970c31c96957956ca39c70942aa599ea3..ca781de0ac4a9ab115fea46c4f3474a997bf4ea3 100644 (file)
@@ -1351,6 +1351,7 @@ menu "Database"
        source "package/leveldb/Config.in"
        source "package/libgit2/Config.in"
        source "package/libodb/Config.in"
+       source "package/libodb-boost/Config.in"
        source "package/libodb-mysql/Config.in"
        source "package/libodb-pgsql/Config.in"
        source "package/libpqxx/Config.in"
diff --git a/package/libodb-boost/Config.in b/package/libodb-boost/Config.in
new file mode 100644 (file)
index 0000000..ada8773
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_LIBODB_BOOST
+       bool "libodb-boost"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_PACKAGE_BOOST
+       select BR2_PACKAGE_LIBODB
+       help
+         This package contains the common ODB runtime library. Every
+         application that includes code generated by the ODB compiler
+         will need to link to this library.
+
+         https://www.codesynthesis.com/products/odb/
+
+comment "libodb-boost needs a toolchain w/ C++, threads"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_PACKAGE_BOOST
diff --git a/package/libodb-boost/libodb-boost.hash b/package/libodb-boost/libodb-boost.hash
new file mode 100644 (file)
index 0000000..622067c
--- /dev/null
@@ -0,0 +1,6 @@
+# From https://www.codesynthesis.com/projects/libcutl/
+sha1  f813702b2856732e199ae34e3393b8cecff878ef  libodb-boost-2.4.0.tar.bz2
+
+# Locally computed
+sha256  b41bd4aaa3f3c9563cfa41bae19bda1bbcc3652e4430b4ebb1819eef2ffcadf4  libodb-boost-2.4.0.tar.bz2
+sha256  841105a470fc283851c63941510ffd403c726d1910b688f7df95914ab8b1b5a3  LICENSE
diff --git a/package/libodb-boost/libodb-boost.mk b/package/libodb-boost/libodb-boost.mk
new file mode 100644 (file)
index 0000000..679c9d7
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libodb-boost
+#
+################################################################################
+
+LIBODB_BOOST_VERSION_MAJOR = 2.4
+LIBODB_BOOST_VERSION = $(LIBODB_BOOST_VERSION_MAJOR).0
+LIBODB_BOOST_SOURCE = libodb-boost-$(LIBODB_BOOST_VERSION).tar.bz2
+LIBODB_BOOST_SITE = https://www.codesynthesis.com/download/odb/$(LIBODB_BOOST_VERSION_MAJOR)
+LIBODB_BOOST_INSTALL_STAGING = YES
+LIBODB_BOOST_LICENSE = GPL-2.0
+LIBODB_BOOST_LICENSE_FILES = LICENSE
+LIBODB_BOOST_DEPENDENCIES = boost libodb
+
+$(eval $(autotools-package))