package/vte: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:34 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:48 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/vte/vte.mk

index 0d5db34b62ce009b81eba2023e4e5796f6625756..6c8d1433f5374d506acae4f5709e22a5ecf4239c 100644 (file)
@@ -10,7 +10,14 @@ VTE_SITE = http://ftp.gnome.org/pub/gnome/sources/vte/0.48
 VTE_DEPENDENCIES = host-intltool host-pkgconf libgtk3 libxml2 pcre2
 VTE_LICENSE = LGPL-2.1+
 VTE_LICENSE_FILES = COPYING
-VTE_CONF_OPTS += --disable-introspection --disable-vala
+VTE_CONF_OPTS += --disable-vala
+
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+VTE_CONF_OPTS += --enable-introspection
+VTE_DEPENDENCIES += gobject-introspection
+else
+VTE_CONF_OPTS += --disable-introspection
+endif
 
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 VTE_CONF_OPTS += --with-gnutls