package/samba4: add required python deps for AD DC support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 4 Apr 2021 16:58:23 +0000 (18:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 20 Apr 2021 21:46:51 +0000 (23:46 +0200)
Needed due to upstream commit:
https://gitlab.com/samba-team/samba/-/commit/2420b7c6d2038aca33759ca3a7d41240c5f19bf7

Fixes:
http://autobuild.buildroot.net/results/12a/12a74665a2349eacb28c3035bb36a4dce1d740d1/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/samba4/Config.in
package/samba4/samba4.mk

index 552afe90cdcc88930297a475de86da13cc583079..e114a7e13f86a10c1a9bfde10567a701e46f6e35 100644 (file)
@@ -32,6 +32,8 @@ config BR2_PACKAGE_SAMBA4_AD_DC
        bool "AD DC"
        depends on BR2_PACKAGE_PYTHON3
        select BR2_PACKAGE_JANSSON
+       select BR2_PACKAGE_PYTHON_DNSPYTHON
+       select BR2_PACKAGE_PYTHON_MARKDOWN
        select BR2_PACKAGE_SAMBA4_ADS
        help
          Enable Active Directory Domain Controller functionality.
index 99c8af9ab2cbbe558833f7b2baccb787b8f3f92d..ce412089819cc79e5f5108f5ec4998b0369a7020 100644 (file)
@@ -149,7 +149,15 @@ define SAMBA4_INSTALL_TARGET_CMDS
 endef
 
 ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),y)
-SAMBA4_DEPENDENCIES += jansson
+# host-python-dnspython and host-python-markdown are not strictly
+# needed on the host, but on the target. however, samba's configure
+# tests for their availability on the host.
+SAMBA4_DEPENDENCIES += \
+       jansson \
+       host-python-dnspython \
+       host-python-markdown \
+       python-dnspython \
+       python-markdown
 else
 SAMBA4_CONF_OPTS += --without-ad-dc --without-json
 endif