quota: rename patch to the new convention
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Nov 2014 13:30:52 +0000 (14:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 9 Nov 2014 20:45:46 +0000 (21:45 +0100)
As a preparation to the introduction of an additional patch to quota,
let's rename the existing patch to the new naming convention.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/quota/01-tools-getrpcbynumber.patch [new file with mode: 0644]
package/quota/quota-01-tools-getrpcbynumber.patch [deleted file]

diff --git a/package/quota/01-tools-getrpcbynumber.patch b/package/quota/01-tools-getrpcbynumber.patch
new file mode 100644 (file)
index 0000000..899db91
--- /dev/null
@@ -0,0 +1,42 @@
+allow usage of getrpcbynumber() instead of getrpcbynumber_r()
+
+libtirpc does not implement the reentrant function getrpcbynumber_r(),
+so allow quota to use the non-reentrant version getrpcbynumber(). This
+should not be a problem as quota tools are not multi-threaded.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/configure.in
+===================================================================
+--- a/configure.in
++++ b/configure.in
+@@ -182,6 +182,12 @@
+ AC_C_CONST
+ AC_C_INLINE
++AC_CHECK_FUNCS([getrpcbynumber getrpcbynumber_r])
++
++if test "$ac_cv_func_getrpcbynumber_r" != "yes" -a "$ac_cv_func_getrpcbynumber" != "yes"; then
++   AC_MSG_ERROR([Neither getrpcbynumber_r nor getrpcbynumber are available])
++fi
++
+ AC_ARG_ENABLE(rpc,
+       [  --enable-rpc=[yes/no]           Enable RPC support [default=yes].],
+       ,
+Index: b/svc_socket.c
+===================================================================
+--- a/svc_socket.c
++++ b/svc_socket.c
+@@ -55,7 +55,12 @@
+       addr.sin_family = AF_INET;
+       if (!port) {
++#if HAVE_GETRPCBYNUMBER_R
+               ret = getrpcbynumber_r(number, &rpcbuf, rpcdata, sizeof(rpcdata), &rpcp);
++#else
++              rpcp = getrpcbynumber(number);
++              ret = 0;
++#endif
+               if (ret == 0 && rpcp != NULL) {
+                       /* First try name */
+                       ret = getservbyname_r(rpcp->r_name, proto, &servbuf, servdata,
diff --git a/package/quota/quota-01-tools-getrpcbynumber.patch b/package/quota/quota-01-tools-getrpcbynumber.patch
deleted file mode 100644 (file)
index 899db91..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-allow usage of getrpcbynumber() instead of getrpcbynumber_r()
-
-libtirpc does not implement the reentrant function getrpcbynumber_r(),
-so allow quota to use the non-reentrant version getrpcbynumber(). This
-should not be a problem as quota tools are not multi-threaded.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/configure.in
-===================================================================
---- a/configure.in
-+++ b/configure.in
-@@ -182,6 +182,12 @@
- AC_C_CONST
- AC_C_INLINE
-+AC_CHECK_FUNCS([getrpcbynumber getrpcbynumber_r])
-+
-+if test "$ac_cv_func_getrpcbynumber_r" != "yes" -a "$ac_cv_func_getrpcbynumber" != "yes"; then
-+   AC_MSG_ERROR([Neither getrpcbynumber_r nor getrpcbynumber are available])
-+fi
-+
- AC_ARG_ENABLE(rpc,
-       [  --enable-rpc=[yes/no]           Enable RPC support [default=yes].],
-       ,
-Index: b/svc_socket.c
-===================================================================
---- a/svc_socket.c
-+++ b/svc_socket.c
-@@ -55,7 +55,12 @@
-       addr.sin_family = AF_INET;
-       if (!port) {
-+#if HAVE_GETRPCBYNUMBER_R
-               ret = getrpcbynumber_r(number, &rpcbuf, rpcdata, sizeof(rpcdata), &rpcp);
-+#else
-+              rpcp = getrpcbynumber(number);
-+              ret = 0;
-+#endif
-               if (ret == 0 && rpcp != NULL) {
-                       /* First try name */
-                       ret = getservbyname_r(rpcp->r_name, proto, &servbuf, servdata,