msmtp: bump to version 1.6.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 2 Jan 2015 22:45:07 +0000 (19:45 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 3 Jan 2015 21:11:00 +0000 (22:11 +0100)
In addition to bumping the version:

 - drop license comment from help, we have PKG_LICENSE* for that.
 - add optional dependency on libsecret
 - remove --without-gnome-keyring option

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/msmtp/Config.in
package/msmtp/msmtp.hash
package/msmtp/msmtp.mk

index 385ad90d206ba9a1b8a7cc38b33f38cf2ca51c07..46bb1985e3e026330f821b41147d13b78ff1be4b 100644 (file)
@@ -5,6 +5,4 @@ config BR2_PACKAGE_MSMTP
          mail to an SMTP server (for example at a free mail provider)
          which takes care of further delivery.
 
-         Note that msmtp is licensed under GPLv3.
-
          http://msmtp.sourceforge.net/
index 41c6caae6cf6f7e41bc30cc82811c38f4d63653b..2196afbb012b6c17e5172a73373a2b9c76f59a95 100644 (file)
@@ -1,2 +1,3 @@
-# Locally computed:
-sha256  2bf0c5c7e78f9905f48de235a75111a1a88238793043bbeae00360b22f1a5f88  msmtp-1.4.32.tar.bz2
+# From http://sourceforge.net/projects/msmtp/files/msmtp/1.6.0/
+md5    1c166853b63c02ae2ab56b50f1aae57b        msmtp-1.6.0.tar.xz
+sha1   39e597619f797ec3550c0146cd3d9e55e85947eb        msmtp-1.6.0.tar.xz
index 2d8e6307211d0e4b77ebb3677ed7a15ed8abc5fe..1c6de1655d02c4d63c3c05ff81d19901b62556b6 100644 (file)
@@ -4,13 +4,22 @@
 #
 ################################################################################
 
-MSMTP_VERSION = 1.4.32
+MSMTP_VERSION = 1.6.0
 MSMTP_SITE = http://downloads.sourceforge.net/project/msmtp/msmtp/$(MSMTP_VERSION)
-MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.bz2
+MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.xz
+MSMTP_DEPENDENCIES = host-pkgconf
+MSMTP_CONF_OPTS = \
+       --without-libidn \
+       --without-libgsasl
 MSMTP_LICENSE = GPLv3+
 MSMTP_LICENSE_FILES = COPYING
 
-MSMTP_DEPENDENCIES += host-pkgconf
+ifeq ($(BR2_PACKAGE_LIBSECRET),y)
+MSMTP_CONF_OPTS += --with-libsecret
+MSMTP_DEPENDENCIES += libsecret
+else
+MSMTP_CONF_OPTS += --without-libsecret
+endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 MSMTP_CONF_OPTS += --with-ssl=openssl
@@ -26,9 +35,4 @@ else
 MSMTP_CONF_OPTS += --with-ssl=no
 endif
 
-MSMTP_CONF_OPTS += \
-       --without-libidn \
-       --without-libgsasl \
-       --without-gnome-keyring
-
 $(eval $(autotools-package))