package/nodejs: add support for building on aarch64 architectures
authorDaniel Mack <daniel@zonque.org>
Fri, 13 Jan 2017 10:55:25 +0000 (11:55 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 13 Jan 2017 15:07:18 +0000 (16:07 +0100)
Signed-off-by: Daniel Mack <daniel@zonque.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nodejs/Config.in
package/nodejs/nodejs.mk

index d2262beb9b3e0c1b00bc8a1a8cfa09e69e99fa0e..b8c45f5dcdf7122082aa0247c750d8fc0ab509f4 100644 (file)
@@ -1,6 +1,6 @@
 comment "nodejs needs a toolchain w/ C++, dynamic library, threads, gcc >= 4.8, wchar"
        depends on BR2_USE_MMU
-       depends on BR2_arm || BR2_i386 || BR2_x86_64 || BR2_mipsel
+       depends on BR2_arm || BR2_aarch64 || BR2_i386 || BR2_x86_64 || BR2_mipsel
        depends on !BR2_MIPS_SOFT_FLOAT
        depends on !BR2_ARM_CPU_ARMV4
        depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS || \
@@ -10,7 +10,7 @@ config BR2_PACKAGE_NODEJS
        bool "nodejs"
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_INSTALL_LIBSTDCPP
-       depends on BR2_arm || BR2_i386 || BR2_x86_64 || BR2_mipsel
+       depends on BR2_arm || BR2_aarch64 || BR2_i386 || BR2_x86_64 || BR2_mipsel
        depends on !BR2_MIPS_SOFT_FLOAT
        # ARM needs BLX, so v5t+
        depends on !BR2_ARM_CPU_ARMV4
index 81006f582fb1ec838832dbfb7f4a252dfbc5091e..43b616960583c55dc2d0edea3044e94cb9de4c69 100644 (file)
@@ -90,6 +90,8 @@ else ifeq ($(BR2_mipsel),y)
 NODEJS_CPU = mipsel
 else ifeq ($(BR2_arm),y)
 NODEJS_CPU = arm
+else ifeq ($(BR2_aarch64),y)
+NODEJS_CPU = arm64
 # V8 needs to know what floating point ABI the target is using.
 NODEJS_ARM_FP = $(call qstrip,$(BR2_GCC_TARGET_FLOAT_ABI))
 endif