Make sure the root/etc/init.d directory is there.
authorManuel Novoa III <mjn3@codepoet.org>
Sun, 2 Nov 2003 02:09:13 +0000 (02:09 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Sun, 2 Nov 2003 02:09:13 +0000 (02:09 -0000)
make/openssh.mk

index 8f37abd0c95846dfd880c9d25062eb8c4d5fe245..415835269d8ddc4a92248a2f7616012d3e7e230a 100644 (file)
@@ -59,6 +59,7 @@ $(OPENSSH_DIR)/ssh: $(OPENSSH_DIR)/.configured
 
 $(TARGET_DIR)/usr/bin/ssh: $(OPENSSH_DIR)/ssh
        $(MAKE) CC=$(TARGET_CC) DESTDIR=$(TARGET_DIR) -C $(OPENSSH_DIR) install
+       mkdir -p $(TARGET_DIR)/etc/init.d/
        cp $(OPENSSH_DIR)/S50sshd $(TARGET_DIR)/etc/init.d/
        chmod a+x $(TARGET_DIR)/etc/init.d/S50sshd
        rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc