package/ntp: fix build for toolchains without ssp
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 23 Mar 2017 19:37:00 +0000 (20:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Mar 2017 13:55:24 +0000 (14:55 +0100)
ntp defaults to use ssp support
http://bk1.ntp.org/ntp-stable/sntp/harden/README

by using these flags
http://bk1.ntp.org/ntp-stable/sntp/harden/linux

If the toolchain lacks SSP support this patch forces ntp to use an
empty set of flags: http://bk1.ntp.org/ntp-stable/sntp/harden/default

Fixes
http://autobuild.buildroot.net/results/1d5/1d58bd8745b22c8eb71fea4c7255d3ace69f6f7a/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ntp/ntp.mk

index b6eb1b186339e23eb02c5298a7fbacfa1002dacf..e3e53a803ffc7d9949703b6e57ec92d7a226950e 100644 (file)
@@ -23,6 +23,12 @@ NTP_CONF_OPTS = \
 # 0002-ntp-syscalls-fallback.patch
 NTP_AUTORECONF = YES
 
+ifeq ($(BR2_TOOLCHAIN_HAS_SSP),y)
+NTP_CONF_OPTS += --with-locfile=linux
+else
+NTP_CONF_OPTS += --with-locfile=default
+endif
+
 ifeq ($(BR2_PACKAGE_LIBCAP),y)
 NTP_CONF_OPTS += --enable-linuxcaps
 NTP_DEPENDENCIES += libcap