package/autotools: add --{enable,disable}-{shared,static} automatically
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 30 May 2011 21:57:02 +0000 (23:57 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 Jun 2011 19:59:34 +0000 (21:59 +0200)
For target packages, depending on BR2_PREFER_STATIC_LIB, add the
correct combination of --{enable,disable}-{shared,static} flags to
./configure calls.

  * When BR2_PREFER_STATIC_LIB is enabled, we pass --enable-static
  --disable-shared.

  * When BR2_PREFER_STATIC_LIB is disabled, we pass --enable-static
  --enable-shared. We enable static libraries since they can still be
  useful to statically link applications against some libraries
  (sometimes it is useful for size reasons). Static libraries are
  anyway only installed in the STAGING_DIR, so it doesn't increase in
  any way the size of the TARGET_DIR.

For host packages, always pass --enable-shared and --disable-static.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in
package/Makefile.in

index 917600ca0be95e3a1ab002bc5c82854136ffddbf..46ab861c13977ba7d8d1e0f37ba2e5bdb2f4dd59 100644 (file)
@@ -104,6 +104,7 @@ define $(2)_CONFIGURE_CMDS
                $$(DISABLE_NLS) \
                $$(DISABLE_LARGEFILE) \
                $$(DISABLE_IPV6) \
+               $$(SHARED_STATIC_LIBS_OPTS) \
                $$(QUIET) $$($$(PKG)_CONF_OPT) \
        )
 endef
@@ -119,6 +120,7 @@ define $(2)_CONFIGURE_CMDS
                ./configure \
                --prefix="$$(HOST_DIR)/usr" \
                --sysconfdir="$$(HOST_DIR)/etc" \
+               --enable-shared --disable-static \
                $$($$(PKG)_CONF_OPT) \
        )
 endef
index 31a963920e5b05849b40b581bdaaf596398cb828..8e9637ce8d4d00135358e4e89cd29184cfcfd537 100644 (file)
@@ -276,6 +276,12 @@ else
 ENABLE_DEBUG:=
 endif
 
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+SHARED_STATIC_LIBS_OPTS=--enable-static --disable-shared
+else
+SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
+endif
+
 include package/Makefile.autotools.in
 include package/Makefile.cmake.in
 include package/Makefile.package.in