package/pango/pango.mk: Remove redundant PKG_CONFIG_*
authorDaniel Laird <danieljlaird@hotmail.com>
Mon, 20 Oct 2008 13:57:30 +0000 (13:57 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Mon, 20 Oct 2008 13:57:30 +0000 (13:57 -0000)
Remove the unnecessary PKG_CONFIG_* settings and tidy up some
config options.

Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
package/pango/pango.mk

index 89f0e63371c082004c4238c235cb6df3b15b9bc3..c599fd5a81d7c0f7ba0097aebfba7aea8714735b 100644 (file)
@@ -39,7 +39,7 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                am_getline_needs_run_time_check=no am_cv_func_working_getline=yes \
                gl_cv_func_mkdir_trailing_slash_bug=no gl_cv_func_mkstemp_limitations=no \
                ac_cv_func_working_mktime=yes jm_cv_func_working_re_compile_pattern=yes \
-               ac_use_included_regex=no gl_cv_c_restrict=no PKG_CONFIG_SYSROOT="$(STAGING_DIR)" \
+               ac_use_included_regex=no gl_cv_c_restrict=no)" \
                ac_cv_path_GLIB_GENMARSHAL=$(HOST_GLIB)/bin/glib-genmarshal ac_cv_path_FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
                
 ifneq ($(BR2_PACKAGE_XSERVER_none),y)
@@ -50,19 +50,10 @@ else
         PANGO_CONF_OPT_X = --without-x
 endif
 
-PANGO_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
-               --build=$(GNU_HOST_NAME) --prefix=/usr --exec-prefix=/usr \
-               --bindir=/usr/bin --sbindir=/usr/sbin \
-               --libdir=/usr/lib --libexecdir=/usr/lib \
-               --sysconfdir=/etc --datadir=/usr/share \
-               --localstatedir=/var --includedir=/usr/include \
-               --mandir=/usr/man --infodir=/usr/info \
-               --enable-shared --enable-static \
+PANGO_CONF_OPT = --enable-shared --enable-static \
                $(PANGO_CONF_OPT_X) \
-               --enable-explicit-deps=no --disable-debug PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
-
+               --enable-explicit-deps=no --disable-debug
 
 PANGO_DEPENDENCIES = uclibc gettext libintl pkgconfig libglib2 $(XSERVER) cairo
 
-
 $(eval $(call AUTOTARGETS,package,pango))