fs/ubifs: work around fakeroot / sed -i issue on systems with SELinux enabled
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 26 Nov 2016 23:40:27 +0000 (00:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Nov 2016 19:31:37 +0000 (20:31 +0100)
Fixes #9386

GNU sed -i misbehaves on systems with SELinux enabled, as it tries to copy
to the SELinux security context (xattr) from the source file to to the new
destination file, which fails under fakeroot and leaves the file with 000
permissions, causing ubinize to fail when it cannot read to configuration
file.

So as a workaround, combine the install and tweak steps in a single
sed with a redirect to the destination file instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/ubifs/ubi.mk

index cda4bf489edd84c3eeeb277bf164f17be569ab9a..e488cb5f8a30e2214baeec025983ccdfc4babeb5 100644 (file)
@@ -20,9 +20,11 @@ else
 UBINIZE_CONFIG_FILE_PATH = fs/ubifs/ubinize.cfg
 endif
 
+# don't use sed -i as it misbehaves on systems with SELinux enabled when this is
+# executed through fakeroot (see #9386)
 define ROOTFS_UBI_CMD
-       $(INSTALL) -m 0644 $(UBINIZE_CONFIG_FILE_PATH) $(BUILD_DIR)/ubinize.cfg
-       $(SED) 's;BR2_ROOTFS_UBIFS_PATH;$@fs;' $(BUILD_DIR)/ubinize.cfg
+       sed 's;BR2_ROOTFS_UBIFS_PATH;$@fs;' \
+               $(UBINIZE_CONFIG_FILE_PATH) > $(BUILD_DIR)/ubinize.cfg
        $(HOST_DIR)/usr/sbin/ubinize -o $@ $(UBI_UBINIZE_OPTS) $(BUILD_DIR)/ubinize.cfg
        rm $(BUILD_DIR)/ubinize.cfg
 endef