python-typing: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 12 Oct 2018 08:06:49 +0000 (10:06 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Oct 2018 20:10:28 +0000 (21:10 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Reviewed-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-typing/Config.in [new file with mode: 0644]
package/python-typing/python-typing.hash [new file with mode: 0644]
package/python-typing/python-typing.mk [new file with mode: 0644]

index 94e19e4a191cc11b37bc7e4a730144426e403dac..7e8224cc7e54654f8c81f7c4b89647ed626268f8 100644 (file)
@@ -1041,6 +1041,7 @@ menu "External python modules"
        source "package/python-txaio/Config.in"
        source "package/python-txtorcon/Config.in"
        source "package/python-typepy/Config.in"
+       source "package/python-typing/Config.in"
        source "package/python-u-msgpack/Config.in"
        source "package/python-ubjson/Config.in"
        source "package/python-ujson/Config.in"
diff --git a/package/python-typing/Config.in b/package/python-typing/Config.in
new file mode 100644 (file)
index 0000000..d5350bc
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_TYPING
+       bool "python-typing"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         Type Hints for Python. This is a backport of the standard library
+         typing module to Python versions older than 3.5.
+
+         https://docs.python.org/3/library/typing.html
diff --git a/package/python-typing/python-typing.hash b/package/python-typing/python-typing.hash
new file mode 100644 (file)
index 0000000..5bdb8c6
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/typing/json
+md5    64614206b4bdc0864fc0e0bccd69efc9  typing-3.6.6.tar.gz
+sha256 4027c5f6127a6267a435201981ba156de91ad0d1d98e9ddc2aa173453453492d  typing-3.6.6.tar.gz
+# Locally computed sha256 checksums
+sha256 ff17ce94e102024deb68773eb1cc74ca76da4e658f373531f0ac22d68a6bb1ad  LICENSE
diff --git a/package/python-typing/python-typing.mk b/package/python-typing/python-typing.mk
new file mode 100644 (file)
index 0000000..acb5316
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-typing
+#
+################################################################################
+
+PYTHON_TYPING_VERSION = 3.6.6
+PYTHON_TYPING_SOURCE = typing-$(PYTHON_TYPING_VERSION).tar.gz
+PYTHON_TYPING_SITE = https://files.pythonhosted.org/packages/bf/9b/2bf84e841575b633d8d91ad923e198a415e3901f228715524689495b4317
+PYTHON_TYPING_SETUP_TYPE = setuptools
+PYTHON_TYPING_LICENSE = Python-2.0, others
+PYTHON_TYPING_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))