Fixes for Qt from Markus Heidelberg
authorArnar Mar Sigurðsson <antab@valka.is>
Sun, 2 Nov 2008 02:16:53 +0000 (02:16 -0000)
committerArnar Mar Sigurðsson <antab@valka.is>
Sun, 2 Nov 2008 02:16:53 +0000 (02:16 -0000)
package/qtopia4/Config.gfx.in
package/qtopia4/Config.in
package/qtopia4/Config.mouse.in
package/qtopia4/Config.sql.in
package/qtopia4/qtopia4.mk

index 572e810a4202c64aad94e78e8afd316ffdec34fc..8147886196b4abf47025251732a328b1ebd48b35 100644 (file)
@@ -6,18 +6,14 @@ config BR2_PACKAGE_QTOPIA4_GFX_LINUXFB
 
 config BR2_PACKAGE_QTOPIA4_GFX_TRANSFORMED
        bool "Transformed"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_GFX_QVFB
        bool "Qt Virtual Framebuffer"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_GFX_VNC
        bool "VNC"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_GFX_MULTISCREEN
        bool "multiscreen"
-       default y
 
 endmenu
index 1c2f948877b41ad9a80bf0c0e5da4c19f808584c..fb156af3da19f21c9e91551fa113290964fe28ab 100644 (file)
@@ -185,7 +185,7 @@ choice
          Select freetype2 support.
 
 config BR2_PACKAGE_QTOPIA4_NOFREETYPE
-        bool "no freetype2 support"
+       bool "no freetype2 support"
        help
          Do not compile in Freetype2 support.
 
index 5ca4046d02b3bcb30d71d333e2b4bbd4c8d0e0cf..7b3946009307d3e3f9454557ba69b69cb2ad4c39 100644 (file)
@@ -2,30 +2,23 @@ menu "Mouse drivers"
 
 config BR2_PACKAGE_QTOPIA4_MOUSE_PC
        bool "pc"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_MOUSE_BUS
        bool "bus"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_MOUSE_LINUXTP
        bool "linuxtp"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_MOUSE_YOPY
        bool "yopy"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_MOUSE_VR41XX
-       bool "vxr41xx"
-       default n
+       bool "vr41xx"
 
 config BR2_PACKAGE_QTOPIA4_MOUSE_TSLIB
        bool "tslib"
-       default n
 
 config BR2_PACKAGE_QTOPIA4_MOUSE_QVFB
        bool "qvfb"
-       default n
 
 endmenu
index 881f7edb626883bc7fec7f9b751add0dd46de973..4c5f405e236f2bcaea6df4a111c7a5bebe5411c7 100644 (file)
@@ -1,7 +1,7 @@
 menuconfig BR2_PACKAGE_QTOPIA4_SQL_MODULE
-    bool "SQL Module"
-    help
-      Compile Qtopia SQL Module
+       bool "SQL Module"
+       help
+         Compile Qtopia SQL Module
 
 if BR2_PACKAGE_QTOPIA4_SQL_MODULE
 config BR2_PACKAGE_QTOPIA4_MYSQL
index cadaaa661d55213638c9ef2bb73c6d6d1066ec63..8b0415f25aa45c3e8aa20ef455c7b5c547307aad 100644 (file)
@@ -95,32 +95,32 @@ endif
 
 ### Mouse drivers
 ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_PC),y)
-QTOPIA4_CONFIGURE += qt-mouse-pc
+QTOPIA4_CONFIGURE += -qt-mouse-pc
 else
 QTOPIA4_CONFIGURE += -no-mouse-pc
 endif
 ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_BUS),y)
-QTOPIA4_CONFIGURE += qt-mouse-bus
+QTOPIA4_CONFIGURE += -qt-mouse-bus
 else
 QTOPIA4_CONFIGURE += -no-mouse-bus
 endif
 ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_LINUXTP),y)
-QTOPIA4_CONFIGURE += qt-mouse-linuxtp
+QTOPIA4_CONFIGURE += -qt-mouse-linuxtp
 else
 QTOPIA4_CONFIGURE += -no-mouse-linuxtp
 endif
 ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_YOPY),y)
-QTOPIA4_CONFIGURE += qt-mouse-yopy
+QTOPIA4_CONFIGURE += -qt-mouse-yopy
 else
 QTOPIA4_CONFIGURE += -no-mouse-yopy
 endif
 ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_VR41XX),y)
-QTOPIA4_CONFIGURE += qt-mouse-vr41xx
+QTOPIA4_CONFIGURE += -qt-mouse-vr41xx
 else
 QTOPIA4_CONFIGURE += -no-mouse-vr41xx
 endif
 ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_TSLIB),y)
-QTOPIA4_CONFIGURE += qt-mouse-tslib
+QTOPIA4_CONFIGURE += -qt-mouse-tslib
 QTOPIA4_DEP_LIBS+=tslib
 QTOPIA4_TSLIB_DEB="-D TSLIBMOUSEHANDLER_DEBUG"
 QTOPIA4_TSLIB_DEB:=$(strip $(subst ",, $(QTOPIA4_TSLIB_DEB)))
@@ -128,6 +128,11 @@ QTOPIA4_TSLIB_DEB:=$(strip $(subst ",, $(QTOPIA4_TSLIB_DEB)))
 else
 QTOPIA4_CONFIGURE += -no-mouse-tslib
 endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_QVFB),y)
+QTOPIA4_CONFIGURE += -qt-mouse-qvfb
+else
+QTOPIA4_CONFIGURE += -no-mouse-qvfb
+endif
 
 ifeq ($(BR2_PACKAGE_QTOPIA4_DEBUG),y)
 QTOPIA4_CONFIGURE+= "-debug $(QTOPIA4_TSLIB_DEB)"