linux-tools: perf: Add dependencies for binutils and openssl
authorRobert Hancock <hancock@sedsystems.ca>
Mon, 2 Mar 2020 22:49:34 +0000 (16:49 -0600)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 19 Mar 2020 17:28:02 +0000 (18:28 +0100)
perf auto-detects and uses the libbfd (from binutils) and openssl
libraries if they are detected and happen to be built before perf is,
but if they're not, or if per-package directories are enabled, it won't
detect these libraries. Explicitly add dependencies on these packages if
they are enabled, and disable the feature if not, so that the behavior
is deterministic.

Signed-off-by: Robert Hancock <hancock@sedsystems.ca>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/linux-tools/linux-tool-perf.mk.in

index 80e00c3c56e5a5a8e913a9a2c8a13884d03d91d5..7106b622cb200412918f151f37758bcc184ab8b8 100644 (file)
@@ -82,6 +82,18 @@ else
 PERF_MAKE_FLAGS += NO_LIBELF=1 NO_DWARF=1
 endif
 
+ifeq ($(BR2_PACKAGE_BINUTILS),y)
+PERF_DEPENDENCIES += binutils
+else
+PERF_MAKE_FLAGS += NO_DEMANGLE=1
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+PERF_DEPENDENCIES += openssl
+else
+PERF_MAKE_FLAGS += NO_LIBCRYPTO=1
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 PERF_DEPENDENCIES += zlib
 else