reinstate AVR32 toolchain
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Wed, 26 Sep 2007 05:36:11 +0000 (05:36 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Wed, 26 Sep 2007 05:36:11 +0000 (05:36 -0000)
target/device/Toolchain.in
toolchain/Config.in
toolchain/binutils/binutils.mk
toolchain/external-toolchain/Config.in
toolchain/gcc/gcc-uclibc-3.x.mk
toolchain/gcc/gcc-uclibc-4.x.mk
toolchain/gdb/gdb.mk
toolchain/uClibc/uclibc.mk

index fc4d04a0d33d6a7dc9b12d47b63cdd065a26deaa..6a35332e43c7798767ed3adb938ead4d4cd3a1c3 100644 (file)
@@ -1,18 +1,30 @@
-if BR2_TOOLCHAIN_EXTERNAL_SOURCE
 choice
        prompt "Source location:"
-#      default BR2_TOOLCHAIN_ATMEL_AVR32 if BR2_avr32
+       default BR2_TOOLCHAIN_NORMAL            if!BR2_avr32
+       default BR2_TOOLCHAIN_ATMEL_AVR32       if BR2_avr32
+       depends on BR2_TOOLCHAIN_BUILDROOT
        help
          Select whether to use the toolchain built by the buildroot
          system or an external pre-built toolchain.
 
+config BR2_TOOLCHAIN_NORMAL
+       bool
+       prompt "Use default sources for toolchain"
+       depends on !BR2_avr32
+       help
+         Download vanilla binutils, gcc, uclibc and gdb from their 
+         main download locations, and apply patches from the
+         "toolchain/<package>" directores.
+         I.E: Do not download a prepatched vendor source suite.
+
 config BR2_TOOLCHAIN_ATMEL_AVR32
-       bool "Use prepatched source for AVR32 toolchain"
+       bool
+       prompt "Use prepatched source for AVR32 toolchain"
        depends on BR2_avr32
-#      depends on BR2_GCC_VERSION_4_1_2
-#      depends on BR2_GDB_VERSION_6_4 || !BR2_PACKAGE_GDB
-#      depends on BR2_BINUTILS_VERSION_2_17
-#      depends on BR2_UCLIBC_VERSION_0_9_28_3
+       depends on BR2_GCC_VERSION_4_1_2
+       depends on BR2_GDB_VERSION_6_4 || !BR2_PACKAGE_GDB
+       depends on BR2_BINUTILS_VERSION_2_17
+       depends on BR2_UCLIBC_VERSION_0_9_28_3
 
 endchoice
 
@@ -43,4 +55,3 @@ config BR2_VENDOR_GDB_RELEASE
 config BR2_VENDOR_PATCH_DIR
        string
        default "target/device/Atmel/toolchain/avr32" if BR2_TOOLCHAIN_ATMEL_AVR32
-endif
index 83f1fd0d2a4538c87a7aafab620eb9106957b1d8..10a1be92d93dd86752e673d515e3fd382291490c 100644 (file)
@@ -3,28 +3,16 @@ choice
        prompt "Toolchain type"
        default BR2_TOOLCHAIN_BUILDROOT
        help
-         Select whether to use the toolchain provided by buildroot
-         or an external toolchain.
-
-         Some vendors provide toolchains in binary form, some in
-         source form.
+         Select whether to use the toolchain built by the buildroot
+         system or an external pre-built toolchain.
 
 config BR2_TOOLCHAIN_BUILDROOT
        bool "Buildroot toolchain"
-       depends on !BR2_avr32
 
 config BR2_TOOLCHAIN_EXTERNAL
-       bool "External binary toolchain"
-
-config BR2_TOOLCHAIN_EXTERNAL_SOURCE
-       bool "External source toolchain"
+       bool "External toolchain"
 endchoice
 
-config BR2_TOOLCHAIN_SOURCE
-       bool
-       default y if BR2_TOOLCHAIN_BUILDROOT || BR2_TOOLCHAIN_EXTERNAL_SOURCE
-       default n if BR2_TOOLCHAIN_EXTERNAL
-
 source "target/device/Toolchain.in"
 
 source "toolchain/Config.in.2"
index 7ca7a55ee754f10e66e09f9ebb3a89e826733d6d..d0546d457359fe63364536dd0806f6da76360fb0 100644 (file)
@@ -65,13 +65,13 @@ BINUTILS_TARGET_CONFIG_OPTIONS=--with-gmp="$(GMP_TARGET_DIR)"
 BINUTILS_TARGET_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_TARGET_DIR)"
 endif
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),)
 BINUTILS_SITE:=$(VENDOR_SITE)
 endif
 
 BINUTILS_OFFICIAL_VERSION:=$(BINUTILS_VERSION)$(VENDOR_SUFFIX)$(VENDOR_BINUTILS_RELEASE)
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
 BINUTILS_PATCH_DIR:=toolchain/binutils/$(BINUTILS_VERSION)
 else
 BINUTILS_PATCH_DIR:=$(VENDOR_PATCH_DIR)/binutils-$(BINUTILS_OFFICIAL_VERSION)
index 18da9795aeec10fae605d80047c1a44de027dfd4..c3a96f713f7d92111d2e7ab8ff3c5c39d81711c3 100644 (file)
@@ -1,8 +1,7 @@
 #
 
-if BR2_TOOLCHAIN_EXTERNAL
-comment "External Toolchain Options"
-
+menu "External Toolchain Options"
+       depends on BR2_TOOLCHAIN_EXTERNAL
 
 config BR2_TOOLCHAIN_EXTERNAL_LIB_C
        string "The core C library from the external toolchain"
@@ -105,4 +104,4 @@ config BR2_TARGET_OPTIMIZATION
        help
          Optimizations to use when building for the target host.
 
-endif
+endmenu
index 0f9a9266aa2714b27862bb5c5df6ff4507a73695..bb34797beb2a904f46d48493aee4ef3821ad07bb 100644 (file)
@@ -33,7 +33,7 @@ endif
 
 
 # redefine if using an external prepatched gcc source
-ifeq ($(BR2_TOOLCHAIN_SOURCE),)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),)
 GCC_SITE:=$(VENDOR_SITE)
 GCC_OFFICIAL_VER:=$(GCC_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GCC_RELEASE)
 endif
@@ -41,7 +41,7 @@ endif
 GCC_SOURCE:=gcc-$(GCC_OFFICIAL_VER).tar.bz2
 GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-$(GCC_OFFICIAL_VER)
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
 ifeq ($(GCC_SNAP_DATE),)
 GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
 else
index 3b2d1c03d749e4884786a14af60935797ccebaa5..7b6ceb0329ae9b8d230cf898ff544a51e2401da3 100644 (file)
@@ -30,13 +30,13 @@ GCC_SITE:=ftp://sources.redhat.com/pub/gcc/snapshots/$(GCC_OFFICIAL_VER)
 endif
 
 # redefine if using an external prepatched gcc source
-ifeq ($(BR2_TOOLCHAIN_SOURCE),)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),)
 GCC_SITE:=$(VENDOR_SITE)
 GCC_OFFICIAL_VER:=$(GCC_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GCC_RELEASE)
 endif
 
 # define patch location
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y) # Normal toolchain
+ifeq ($(BR2_TOOLCHAIN_NORMAL),y) # Normal toolchain
 ifeq ($(GCC_SNAP_DATE),) # Not a snapshot
 GCC_PATCH_DIR:=toolchain/gcc/$(GCC_VERSION)
 else # Is a snapshot
index e7409070851e993aeb766ddc86e5d5229deca127..6486f874bd0551c99e317079442a0a5dc5dcbad9 100644 (file)
@@ -20,7 +20,7 @@ GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(GDB_VERSION)
 GDB_PATCH_DIR:=toolchain/gdb/$(GDB_VERSION)
 else
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
 GDB_SITE:=http://ftp.gnu.org/gnu/gdb
 else
 GDB_SITE:=$(VENDOR_SITE)
@@ -31,7 +31,7 @@ GDB_OFFICIAL_VERSION:=$(GDB_VERSION)$(VENDOR_SUFFIX)$(VENDOR_GDB_RELEASE)
 GDB_SOURCE:=gdb-$(GDB_OFFICIAL_VERSION).tar.bz2
 GDB_CAT:=$(BZCAT)
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
 GDB_PATCH_DIR:=toolchain/gdb/$(GDB_OFFICIAL_VERSION)
 else
 GDB_PATCH_DIR:=$(VENDOR_PATCH_DIR)/gdb-$(GDB_OFFICIAL_VERSION)
index 1c10f1290346d5e67dff92369d7d863392fb822a..5a3e54845eacd60bc3013af23a1619682fd96436 100644 (file)
@@ -34,14 +34,14 @@ UCLIBC_VER:=0.9.28
 endif
 UCLIBC_SITE:=http://www.uclibc.org/downloads
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),)
 UCLIBC_SITE:=$(VENDOR_SITE)
 endif
 
 UCLIBC_OFFICIAL_VERSION:=$(UCLIBC_VER)$(VENDOR_SUFFIX)$(VENDOR_UCLIBC_RELEASE)
 
 
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_NORMAL),y)
 UCLIBC_PATCH_DIR:=toolchain/uClibc/
 else
 UCLIBC_PATCH_DIR:=$(VENDOR_PATCH_DIR)/uClibc-$(UCLIBC_OFFICIAL_VERSION)