flot: add plugins missed from 0.8.0 bump
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 May 2013 09:34:08 +0000 (11:34 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 May 2013 09:35:29 +0000 (11:35 +0200)
A number of plugins were not added when the flot version was bumped.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/flot/Config.in
package/flot/flot.mk

index 90a4278c00444933127edbac83ba8f6c5e04aae4..4c0d3ec334b4684bad48ba2b444d66ca3f09bf74 100644 (file)
@@ -25,11 +25,32 @@ config BR2_PACKAGE_FLOT_CANVAS
        help
          Flot plugin to render axis tick labels directly to the canvas
 
+config BR2_PACKAGE_FLOT_CATEGORIES
+       bool "categories"
+       help
+         Flot plugin for plotting textual data or categories
+
+config BR2_PACKAGE_FLOT_CROSSHAIR
+       bool "crosshair"
+       help
+         Flot plugin for showing crosshairs when the mouse hovers
+         over the plot
+
+config BR2_PACKAGE_FLOT_ERRORBARS
+       bool "errorbars"
+       help
+         Flot plugin for plotting error bars
+
 config BR2_PACKAGE_FLOT_FILLBETWEEN
        bool "fillbetween"
        help
          Flot plugin for computing bottoms for filled line and bar charts
 
+config BR2_PACKAGE_FLOT_IMAGE
+       bool "image"
+       help
+         Flot plugin for plotting images
+
 config BR2_PACKAGE_FLOT_NAVIGATE
        bool "navigate"
        help
@@ -66,4 +87,9 @@ config BR2_PACKAGE_FLOT_THRESHOLD
        help
          Flot plugin for thresholding data
 
+config BR2_PACKAGE_FLOT_TIME
+       bool "time"
+       help
+         Flot plugin for handling time axes
+
 endif
index 97110bccfe9d8b64c8d2f01e84640b7e9b1eb4a9..56cb22e3a2bac3e90ebddf647c3385d5a26abf61 100644 (file)
@@ -4,7 +4,11 @@ FLOT_LICENSE = MIT
 FLOT_LICENSE_FILES = LICENSE.txt
 FLOT_FILES = jquery.flot $(addprefix jquery.flot.,\
        $(if $(BR2_PACKAGE_FLOT_CANVAS),canvas) \
+       $(if $(BR2_PACKAGE_FLOT_CATEGORIES),categories) \
+       $(if $(BR2_PACKAGE_FLOT_CROSSHAIR),crosshair) \
+       $(if $(BR2_PACKAGE_FLOT_ERRORBARS),errorbars) \
        $(if $(BR2_PACKAGE_FLOT_FILLBETWEEN),fillbetween) \
+       $(if $(BR2_PACKAGE_FLOT_IMAGE),image) \
        $(if $(BR2_PACKAGE_FLOT_NAVIGATE),navigate) \
        $(if $(BR2_PACKAGE_FLOT_PIE),pie) \
        $(if $(BR2_PACKAGE_FLOT_RESIZE),resize) \
@@ -12,6 +16,7 @@ FLOT_FILES = jquery.flot $(addprefix jquery.flot.,\
        $(if $(BR2_PACKAGE_FLOT_STACK),stack) \
        $(if $(BR2_PACKAGE_FLOT_SYMBOL),symbol) \
        $(if $(BR2_PACKAGE_FLOT_THRESHOLD),threshold) \
+       $(if $(BR2_PACKAGE_FLOT_TIME),time) \
        )
 
 define FLOT_INSTALL_TARGET_CMDS