package/libfm: add optional support for libexif
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 10:51:25 +0000 (11:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 13:45:36 +0000 (14:45 +0100)
When libexif was compiled before, libfm will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/libfm.so.4.0.3 | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libexif.so.12]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libfm/libfm.mk

index f0888b7e2760321062177208e6bc2eae07375925..e8410d0288d3303fba19dd51e597902f261696d9 100644 (file)
@@ -12,4 +12,11 @@ LIBFM_LICENSE = GPLv2+, LGPLv2.1+
 LIBFM_LICENSE_FILES = COPYING src/extra/fm-xml-file.c
 LIBFM_INSTALL_STAGING = YES
 
+ifeq ($(BR2_PACKAGE_LIBEXIF),y)
+LIBFM_CONF_OPTS += --enable-exif
+LIBFM_DEPENDENCIES += libexif
+else
+LIBFM_CONF_OPTS += --disable-exif
+endif
+
 $(eval $(autotools-package))