package: add flashbench
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 14 Dec 2012 23:58:02 +0000 (00:58 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 14 Dec 2012 23:58:02 +0000 (00:58 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/flashbench/Config.in [new file with mode: 0644]
package/flashbench/flashbench.mk [new file with mode: 0644]

index dbb6704ede8e8842535b5c1ca0919ff27fc60e37..7607e978920307b73c36f619cca780b9c1806219 100644 (file)
@@ -182,6 +182,7 @@ source "package/cifs-utils/Config.in"
 source "package/cramfs/Config.in"
 source "package/dosfstools/Config.in"
 source "package/e2fsprogs/Config.in"
+source "package/flashbench/Config.in"
 source "package/genext2fs/Config.in"
 source "package/genromfs/Config.in"
 source "package/makedevs/Config.in"
diff --git a/package/flashbench/Config.in b/package/flashbench/Config.in
new file mode 100644 (file)
index 0000000..39cdb1d
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_FLASHBENCH
+       bool "flashbench"
+       depends on BR2_LARGEFILE
+       help
+         Flashbench - Identify characteristics of flash media.
+
+         This is the tool used to identify the properties of
+         SD cards and other media for the Linaro flash memory
+         survey.
+
+         https://wiki.linaro.org/WorkingGroups/KernelConsolidation/Projects/FlashCardSurvey
+
+comment "flashbench requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/flashbench/flashbench.mk b/package/flashbench/flashbench.mk
new file mode 100644 (file)
index 0000000..ead1346
--- /dev/null
@@ -0,0 +1,22 @@
+#############################################################
+#
+# flashbench
+#
+#############################################################
+
+FLASHBENCH_VERSION = 2e30b1968a66147412f21002ea844122a0d5e2f0
+FLASHBENCH_SITE = git://git.linaro.org/people/arnd/flashbench.git
+FLASHBENCH_LICENSE = GPLv2
+FLASHBENCH_LICENSE_FILES = COPYING
+
+define FLASHBENCH_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+               LDFLAGS="$(TARGET_LDFLAGS) -lrt"
+endef
+
+define FLASHBENCH_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 755 -D $(@D)/flashbench $(TARGET_DIR)/usr/bin/flashbench
+       $(INSTALL) -m 755 -D $(@D)/erase $(TARGET_DIR)/usr/bin/erase
+endef
+
+$(eval $(generic-package))