package/gupnp: add optional dependency for gobject-introspection
authorAdam Duskett <Aduskett@gmail.com>
Sun, 15 Mar 2020 17:24:56 +0000 (10:24 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 22 Mar 2020 10:16:52 +0000 (11:16 +0100)
If gobject-introspection is selected, explicitly set --enable-introspection in
the configure options and add a dependency for gobject-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gupnp/gupnp.mk

index 27486b09faccd9a4a39f29c819d08fa31a18bf77..75bbfa8d1d3671f0c9b182e7d7ce73eae43faffa 100644 (file)
@@ -12,6 +12,12 @@ GUPNP_LICENSE = LGPL-2.0+
 GUPNP_LICENSE_FILES = COPYING
 GUPNP_INSTALL_STAGING = YES
 GUPNP_DEPENDENCIES = host-pkgconf libglib2 libxml2 gssdp util-linux
-GUPNP_CONF_OPTS = --disable-introspection
+
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+GUPNP_CONF_OPTS += --enable-introspection
+GUPNP_DEPENDENCIES += gobject-introspection
+else
+GUPNP_CONF_OPTS += --disable-introspection
+endif
 
 $(eval $(autotools-package))