zeromq: add norm support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 9 Mar 2016 09:35:42 +0000 (06:35 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Mar 2016 22:05:16 +0000 (23:05 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Thomas: add explicit --without-norm.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/zeromq/Config.in
package/zeromq/zeromq.mk

index aefdf484930fac1978eecddc812829f0e99927e2..d5c9deae37784426c73b0b0ddbedccf413640293 100644 (file)
@@ -27,6 +27,17 @@ config BR2_PACKAGE_ZEROMQ
 
 if BR2_PACKAGE_ZEROMQ
 
+comment "norm support needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
+
+config BR2_PACKAGE_ZEROMQ_NORM
+       bool "NORM support"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_NORM
+       help
+         Add support for NACK-Oriented Reliable Multicast (RFC 5740)
+         protocol.
+
 config BR2_PACKAGE_ZEROMQ_PGM
        bool "PGM/EPGM support"
        depends on BR2_TOOLCHAIN_HAS_SYNC_2
index b80f8e49a3f24a1463e5cf297173ae60c08c6cba..fbc63a75c5c535a469ab6a3900f8edf29a718dda 100644 (file)
@@ -28,6 +28,13 @@ ifeq ($(BR2_STATIC_LIBS),y)
 ZEROMQ_CONF_OPTS += LIBS=-lstdc++
 endif
 
+ifeq ($(BR2_PACKAGE_ZEROMQ_NORM),y)
+ZEROMQ_CONF_OPTS += --with-norm
+ZEROMQ_DEPENDENCIES += norm
+else
+ZEROMQ_CONF_OPTS += --without-norm
+endif
+
 ifeq ($(BR2_PACKAGE_ZEROMQ_PGM),y)
 ZEROMQ_DEPENDENCIES += host-pkgconf openpgm
 ZEROMQ_CONF_OPTS += --with-pgm