package/pkcs11-helper: fix build without threads
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 1 May 2020 10:27:58 +0000 (12:27 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 1 May 2020 12:10:56 +0000 (14:10 +0200)
Use --{en,dis}able-{threading,slotevent} to fix build without threads

Fixes:
 - http://autobuild.buildroot.org/results/d6eefca3ab1fb86e148e998238eed1df2310775f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: move earlier; use single-line assignments]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkcs11-helper/pkcs11-helper.mk

index a95340daf7dcc964e610a1ec2c6480c18b58cfd6..a651be98bb2ec14f087039b1eff2274d8c492912 100644 (file)
@@ -16,6 +16,12 @@ PKCS11_HELPER_CONF_OPTS = \
        --disable-crypto-engine-polarssl \
        --disable-crypto-engine-cryptoapi
 
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+PKCS11_HELPER_CONF_OPTS += --enable-slotevent --enable-threading
+else
+PKCS11_HELPER_CONF_OPTS += --disable-slotevent --disable-threading
+endif
+
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 PKCS11_HELPER_DEPENDENCIES += gnutls
 PKCS11_HELPER_CONF_OPTS += --enable-crypto-engine-gnutls