package/libargon2: bump to version 20190702
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 15 Feb 2020 10:02:47 +0000 (11:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Apr 2020 14:13:19 +0000 (16:13 +0200)
- There is no incompatibility of this version with php, the issue was
  due to libargon2 itself that installs library to lib/x86_64-linux-gnu
  on Linux x86_64 host since
  https://github.com/P-H-C/phc-winner-argon2/commit/d3639142fa71f8095ee36e64068f71b3c97baf6d
- Update indentation of hash file (two spaces)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libargon2/libargon2.hash
package/libargon2/libargon2.mk

index c524b427184686471fc081b63609f1d23c08d719..331eea99f4af0967f50a15982c7a22e0f47b434b 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 eaea0172c1f4ee4550d1b6c9ce01aab8d1ab66b4207776aa67991eb5872fdcd8  libargon2-20171227.tar.gz
-sha256 220f8736a89ff51c92ef3d497f413b48e6cf1df3d6278bc909c6308c78e1718e  LICENSE
+sha256  daf972a89577f8772602bf2eb38b6a3dd3d922bf5724d45e7f9589b5e830442c  libargon2-20190702.tar.gz
+sha256  220f8736a89ff51c92ef3d497f413b48e6cf1df3d6278bc909c6308c78e1718e  LICENSE
index e10343a15e1ece74912dae1771012b3a6b60b09c..b3f6e1b2169078a77af266cd6d6bb4752d9c7caa 100644 (file)
@@ -4,18 +4,19 @@
 #
 ################################################################################
 
-# 20190702 is not recognized by php7.3
-LIBARGON2_VERSION = 20171227
+LIBARGON2_VERSION = 20190702
 LIBARGON2_SITE = $(call github,P-H-C,phc-winner-argon2,$(LIBARGON2_VERSION))
 LIBARGON2_LICENSE = CC0-1.0 or Apache-2.0
 LIBARGON2_LICENSE_FILES = LICENSE
 LIBARGON2_INSTALL_STAGING = YES
 
+LIBARGON2_OPTS = LIBRARY_REL=lib
+
 # GCC_TARGET_ARCH is not defined for all architectures, but libargon2
 # only uses it to detect if some x86 optimizations can be used, and
 # GCC_TARGET_ARCH is defined on x86.
 ifneq ($(GCC_TARGET_ARCH),)
-LIBARGON2_OPTS = OPTTARGET=$(GCC_TARGET_ARCH)
+LIBARGON2_OPTS += OPTTARGET=$(GCC_TARGET_ARCH)
 endif
 
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
@@ -29,12 +30,12 @@ endef
 
 define LIBARGON2_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-               DESTDIR=$(STAGING_DIR) install
+               $(LIBARGON2_OPTS) DESTDIR=$(STAGING_DIR) install
 endef
 
 define LIBARGON2_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-               DESTDIR=$(TARGET_DIR) install
+               $(LIBARGON2_OPTS) DESTDIR=$(TARGET_DIR) install
 endef
 
 $(eval $(generic-package))