package/yaffs2utils: create $(HOST_DIR)/bin before installation
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 21 Apr 2019 10:32:23 +0000 (12:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 21 Apr 2019 10:32:23 +0000 (12:32 +0200)
The yaffs2utils Makefile uses plain "cp", which fails when
$(HOST_DIR)/bin doesn't exist. Fix that by creationg $(HOST_DIR)/bin
beforehand.

Fixes:

  https://gitlab.com/buildroot.org/buildroot/-/jobs/199339624

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/yaffs2utils/yaffs2utils.mk

index c2a87eac7b42a362e20ac9c393a302eaf49efaa5..d3a8bdc9d2dd6aed8676230263c96f2753fcc5fe 100644 (file)
@@ -15,6 +15,7 @@ define HOST_YAFFS2UTILS_BUILD_CMDS
 endef
 
 define HOST_YAFFS2UTILS_INSTALL_CMDS
+       mkdir -p $(HOST_DIR)/bin
        $(HOST_MAKE_ENV) $(MAKE) -C $(@D) INSTALLDIR=$(HOST_DIR)/bin install
 endef