package/libsigrok: fix configure options
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 27 Oct 2019 17:49:47 +0000 (18:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 27 Oct 2019 18:24:27 +0000 (19:24 +0100)
- Remove --disable-glibtest (unrecognized option)
- Switch --{en,dis}able-xxx options by --{with,without}-xxx options

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libsigrok/libsigrok.mk

index 5bca9ad518e2845a3583b7bc4c22d2f4843abf93..c65d63eb2a87e162805646b02d4489e2b5830ad1 100644 (file)
@@ -10,27 +10,27 @@ LIBSIGROK_LICENSE = GPL-3.0+
 LIBSIGROK_LICENSE_FILES = COPYING
 LIBSIGROK_INSTALL_STAGING = YES
 LIBSIGROK_DEPENDENCIES = libglib2 libzip host-pkgconf
-LIBSIGROK_CONF_OPTS = --disable-glibtest --disable-java --disable-python
+LIBSIGROK_CONF_OPTS = --disable-java --disable-python
 
 ifeq ($(BR2_PACKAGE_LIBSERIALPORT),y)
-LIBSIGROK_CONF_OPTS += --enable-libserialport
+LIBSIGROK_CONF_OPTS += --with-libserialport
 LIBSIGROK_DEPENDENCIES += libserialport
 else
-LIBSIGROK_CONF_OPTS += --disable-libserialport
+LIBSIGROK_CONF_OPTS += --without-libserialport
 endif
 
 ifeq ($(BR2_PACKAGE_LIBFTDI),y)
-LIBSIGROK_CONF_OPTS += --enable-libftdi
+LIBSIGROK_CONF_OPTS += --with-libftdi
 LIBSIGROK_DEPENDENCIES += libftdi
 else
-LIBSIGROK_CONF_OPTS += --disable-libftdi
+LIBSIGROK_CONF_OPTS += --without-libftdi
 endif
 
 ifeq ($(BR2_PACKAGE_LIBUSB),y)
-LIBSIGROK_CONF_OPTS += --enable-libusb
+LIBSIGROK_CONF_OPTS += --with-libusb
 LIBSIGROK_DEPENDENCIES += libusb
 else
-LIBSIGROK_CONF_OPTS += --disable-libusb
+LIBSIGROK_CONF_OPTS += --without-libusb
 endif
 
 ifeq ($(BR2_PACKAGE_GLIBMM),y)