toolchain: remove toolchain-specific stripping
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Dec 2010 16:27:40 +0000 (17:27 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 13 Dec 2010 21:02:32 +0000 (22:02 +0100)
We already handle the stripping of libraries in $(TARGET_DIR) at the
global level, so there's no need to have toolchain-specific option and
code for this.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk
toolchain/toolchain-crosstool-ng/Config.in
toolchain/toolchain-crosstool-ng/crosstool-ng.mk
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 43c6db3245ec789470003d6c365d493e63c1298d..24f379d492b0478632bb57705a1127f86c532cf5 100644 (file)
 # $1: arch specific sysroot directory
 # $2: library name
 # $3: destination directory of the libary, relative to $(TARGET_DIR)
-# $4: strip (y|n), default is to strip
 #
 copy_toolchain_lib_root = \
        ARCH_SYSROOT_DIR="$(strip $1)"; \
        LIB="$(strip $2)"; \
        DESTDIR="$(strip $3)" ; \
-       STRIP="$(strip $4)"; \
  \
        LIBS=`(cd $${ARCH_SYSROOT_DIR}; \
                find -L . -path "./lib/$${LIB}.*"     -o \
@@ -39,13 +37,6 @@ copy_toolchain_lib_root = \
                                cp -d $${FULLPATH} $(TARGET_DIR)/$${DESTDIR}/; \
                        elif test -f $${FULLPATH}; then \
                                $(INSTALL) -D -m0755 $${FULLPATH} $(TARGET_DIR)/$${DESTDIR}/$${LIB}; \
-                               case "$${STRIP}" in \
-                               (0 | n | no) \
-;; \
-                               (*) \
-                                       $(TARGET_CROSS)strip "$(TARGET_DIR)/$${DESTDIR}/$${LIB}"; \
-;; \
-                               esac; \
                        else \
                                exit -1; \
                        fi; \
index 4f305886b5811a30ec0c8765c24e514946afe52c..4ee665dfb07bd659f71bf809f5fd45de501315cb 100644 (file)
@@ -98,10 +98,4 @@ config BR2_TOOLCHAIN_CTNG_uClibc_PROGRAM_INVOCATION
 
 endif # BR2_TOOLCHAIN_CTNG_uClibc
 
-config BR2_TOOLCHAIN_CTNG_STRIP_LIBS
-       bool "Strip libs copied to target"
-       default !BR2_STRIP_none
-       help
-         Strip shared libraries copied from the toolchain.
-
 endif # BR2_TOOLCHAIN_CTNG
index 31797c48712383a19f9a3dd6a9780b1b98a59928..1c5e86431737f871ad8d85345b14c0ffc61c8e63 100644 (file)
@@ -65,10 +65,10 @@ $(STAMP_DIR)/ct-ng-toolchain-installed: $(STAMP_DIR)/ct-ng-toolchain-built
            echo "CTNG_SYSROOT='$${CTNG_SYSROOT}'";                         \
            echo "Copy external toolchain libraries to target...";          \
            for libs in $(CTNG_LIBS_LIB); do                                \
-               $(call copy_toolchain_lib_root,$${CTNG_SYSROOT},$$libs,/lib,$(BR2_TOOLCHAIN_CTNG_STRIP_LIBS)); \
+               $(call copy_toolchain_lib_root,$${CTNG_SYSROOT},$$libs,/lib); \
            done;                                                           \
            for libs in $(CTNG_LIBS_USR_LIB); do                            \
-               $(call copy_toolchain_lib_root,$${CTNG_SYSROOT},$$libs,/usr/lib,$(BR2_TOOLCHAIN_CTNG_STRIP_LIBS)); \
+               $(call copy_toolchain_lib_root,$${CTNG_SYSROOT},$$libs,/usr/lib); \
            done;                                                           \
            echo "Copy external toolchain sysroot to staging...";           \
            $(call copy_toolchain_sysroot,$${CTNG_SYSROOT},$${CTNG_SYSROOT},)
index c2602d2369908e10e9df97ac7c3bf94eafd6a43b..59fcb520de934c3ab33821d2b6b202cbcda7297f 100644 (file)
@@ -218,12 +218,5 @@ endif # BR2_TOOLCHAIN_EXTERNAL_CUSTOM_UCLIBC
 
 endif # BR2_TOOLCHAIN_EXTERNAL_CUSTOM
 
-config BR2_TOOLCHAIN_EXTERNAL_STRIP
-       bool
-       default y
-       prompt "Strip shared libraries"
-       help
-         Strip shared libraries copied from the external toolchain.
-
 endif # BR2_TOOLCHAIN_EXTERNAL
 
index 7a1791473ca00600c2ffdb9542c139940984a08a..027fbbdf584bd781adede358b253113b05bcdef9 100644 (file)
@@ -184,10 +184,10 @@ $(STAMP_DIR)/ext-toolchain-installed: $(TOOLCHAIN_EXTERNAL_DEPENDENCIES)
        mkdir -p $(TARGET_DIR)/lib ; \
        echo "Copy external toolchain libraries to target..." ; \
        for libs in $(LIB_EXTERNAL_LIBS); do \
-               $(call copy_toolchain_lib_root,$${ARCH_SYSROOT_DIR},$$libs,/lib,$(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
+               $(call copy_toolchain_lib_root,$${ARCH_SYSROOT_DIR},$$libs,/lib); \
        done ; \
        for libs in $(USR_LIB_EXTERNAL_LIBS); do \
-               $(call copy_toolchain_lib_root,$${ARCH_SYSROOT_DIR},$$libs,/usr/lib,$(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
+               $(call copy_toolchain_lib_root,$${ARCH_SYSROOT_DIR},$$libs,/usr/lib); \
        done ; \
        echo "Copy external toolchain sysroot to staging..." ; \
        $(call copy_toolchain_sysroot,$${SYSROOT_DIR},$${ARCH_SYSROOT_DIR},$${ARCH_SUBDIR}) ; \