Detect early if an UTF-8 locale is needed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Aug 2010 11:10:54 +0000 (13:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Aug 2010 11:10:54 +0000 (13:10 +0200)
Check in toolchain/dependencies/dependencies.sh if an UTF-8 locale is
properly present on the system before trying to build a locale enabled
toolchain. As this test is only needed when a locale enabled toolchain
is going to be built, we pass the configuration file path to the
dependencies.sh script so that it can grep for the current value of
various options.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/dependencies/dependencies.mk
toolchain/dependencies/dependencies.sh

index d50042462cf44db408968a553fb226af9534d901..b334811ac900c47dc01baf85981b14acc74233d5 100644 (file)
@@ -16,6 +16,7 @@ endif
 dependencies: host-sed $(DEPENDENCIES_HOST_PREREQ)
        @HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
                HOST_SED_DIR="$(HOST_SED_DIR)" \
+               CONFIG_FILE="$(CONFIG_DIR)/.config" \
                $(TOPDIR)/toolchain/dependencies/dependencies.sh
 
 dependencies-source:
index b3822ef667f8bd3c65164c4fef077beb3a6cc83d..b47e9d81ee41ce65b9e2a55db2c2bd60b377fad3 100755 (executable)
@@ -152,3 +152,15 @@ for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio p
        exit 1;
     fi
 done
+
+if grep ^BR2_TOOLCHAIN_BUILDROOT=y $CONFIG_FILE > /dev/null && \
+   grep ^BR2_ENABLE_LOCALE=y       $CONFIG_FILE > /dev/null ; then
+   if ! which locale > /dev/null ; then
+       /bin/echo -e "\nYou need locale support on your build machine to build a toolchain supporting locales\n"
+       exit 1 ;
+   fi
+   if ! locale -a | grep -i utf8$ ; then
+       /bin/echo -e "\nYou need at least one UTF8 locale to build a toolchain supporting locales\n"
+       exit 1 ;
+   fi
+fi