python-pyftpdlib: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 8 Jan 2015 21:28:55 +0000 (22:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Jan 2015 12:54:02 +0000 (13:54 +0100)
[Thomas: remove empty new line at end of .mk file.]

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-pyftpdlib/Config.in [new file with mode: 0644]
package/python-pyftpdlib/python-pyftpdlib.hash [new file with mode: 0644]
package/python-pyftpdlib/python-pyftpdlib.mk [new file with mode: 0644]

index 847677397ecfeb244eed124d006d35721912216a..08fa31d26791f851bcd6db6531dec84d1866ee02 100644 (file)
@@ -530,6 +530,7 @@ menu "external python modules"
        source "package/python-psutil/Config.in"
        source "package/python-pyasn/Config.in"
        source "package/python-pycrypto/Config.in"
+       source "package/python-pyftpdlib/Config.in"
        source "package/python-pygame/Config.in"
        source "package/python-pyparsing/Config.in"
        source "package/python-pypcap/Config.in"
diff --git a/package/python-pyftpdlib/Config.in b/package/python-pyftpdlib/Config.in
new file mode 100644 (file)
index 0000000..e25c34e
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_PYFTPDLIB
+       bool "python-pyftpdlib"
+       help
+         Extremely fast and scalable Python FTP server library.
+
+         https://github.com/giampaolo/pyftpdlib
diff --git a/package/python-pyftpdlib/python-pyftpdlib.hash b/package/python-pyftpdlib/python-pyftpdlib.hash
new file mode 100644 (file)
index 0000000..e1d2e94
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256  e2024de33024582ef26e30395225180048b98cab341f3e9f3a55f56397c9a4b5  python-pyftpdlib-1.4.0.tar.gz
diff --git a/package/python-pyftpdlib/python-pyftpdlib.mk b/package/python-pyftpdlib/python-pyftpdlib.mk
new file mode 100644 (file)
index 0000000..af9423f
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-pyftpdlib
+#
+################################################################################
+
+PYTHON_PYFTPDLIB_VERSION = 1.4.0
+PYTHON_PYFTPDLIB_SITE = $(call github,giampaolo,pyftpdlib,release-$(PYTHON_PYFTPDLIB_VERSION))
+PYTHON_PYFTPDLIB_SETUP_TYPE = setuptools
+PYTHON_PYFTPDLIB_LICENSE = MIT
+PYTHON_PYFTPDLIB_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))