collectd: fix libgcrypt support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 10 Jan 2017 13:06:46 +0000 (10:06 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 10 Jan 2017 20:07:30 +0000 (21:07 +0100)
For the newer versions the collectd configure script expects
libgcrypt-config as parameter rather than the location for the
libgcrypt-config script. Adjust the package to account for this.
Fixes:
http://autobuild.buildroot.net/results/a49/a494bc905e4509528c4932f76a094b9ea8e70bd3/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/collectd.mk

index 7ab7dd4223c0b63a2878d65c4a96308b996e3d36..fa6ebae71ffda80a13316e40391ebcf9e4611a61 100644 (file)
@@ -175,8 +175,7 @@ endif
 # network can use libgcrypt
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
 COLLECTD_DEPENDENCIES += libgcrypt
-COLLECTD_CONF_OPTS += --with-libgcrypt=$(STAGING_DIR)/usr
-COLLECTD_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
+COLLECTD_CONF_OPTS += --with-libgcrypt=$(STAGING_DIR)/usr/bin/libgcrypt-config
 else
 COLLECTD_CONF_OPTS += --with-libgcrypt=no
 endif