yajl: bump version
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 25 Jan 2012 11:03:10 +0000 (12:03 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 25 Jan 2012 11:03:10 +0000 (12:03 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/yajl/yajl-2.0.2-math-link.patch [deleted file]
package/yajl/yajl-2.0.4-math-link.patch [new file with mode: 0644]
package/yajl/yajl.mk

diff --git a/package/yajl/yajl-2.0.2-math-link.patch b/package/yajl/yajl-2.0.2-math-link.patch
deleted file mode 100644 (file)
index 355a248..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-[PATCH] fix json_reformat linking on uClibc
-
-json_reformat calls yajl_gen_* functions, which internally use isnan() /
-isinf(). On Glibc, these are provided by libc, but on uClibc you need to
-link with -lm (like the spec says), so ensure we do so.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- reformatter/CMakeLists.txt |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: yajl-2.0.2/reformatter/CMakeLists.txt
-===================================================================
---- yajl-2.0.2.orig/reformatter/CMakeLists.txt
-+++ yajl-2.0.2/reformatter/CMakeLists.txt
-@@ -26,7 +26,7 @@
- ADD_EXECUTABLE(json_reformat ${SRCS})
--TARGET_LINK_LIBRARIES(json_reformat yajl_s)
-+TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
- # copy the binary into the output directory
- GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
diff --git a/package/yajl/yajl-2.0.4-math-link.patch b/package/yajl/yajl-2.0.4-math-link.patch
new file mode 100644 (file)
index 0000000..355a248
--- /dev/null
@@ -0,0 +1,24 @@
+[PATCH] fix json_reformat linking on uClibc
+
+json_reformat calls yajl_gen_* functions, which internally use isnan() /
+isinf(). On Glibc, these are provided by libc, but on uClibc you need to
+link with -lm (like the spec says), so ensure we do so.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ reformatter/CMakeLists.txt |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: yajl-2.0.2/reformatter/CMakeLists.txt
+===================================================================
+--- yajl-2.0.2.orig/reformatter/CMakeLists.txt
++++ yajl-2.0.2/reformatter/CMakeLists.txt
+@@ -26,7 +26,7 @@
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)
index 723cce4a9883ed50ba8a2ef47a09b169d19d9fe3..1c0df383b0b90efb950cbc45df5fa1c570d1ea40 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-YAJL_VERSION = 2.0.2
+YAJL_VERSION = 2.0.4
 YAJL_SITE = git://github.com/lloyd/yajl.git
 YAJL_INSTALL_STAGING = YES