php: don't use DOWNLOAD macro
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Feb 2009 15:13:50 +0000 (15:13 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Feb 2009 15:13:50 +0000 (15:13 -0000)
php.net only offers downloads though a strange php script with the file name
embedded in the *MIDDLE* of the URL, which isn't compatible with the DOWNLOAD
macro. Fix it by reverting php.mk hunk of r24689 to go back to $(WGET).

This ofcourse means that the primary site / fallback mirror stuff isn't used.

package/php/php.mk

index 86372ed722fcbc6e264cd1213e4f28e02b50308a..836fc2a4d9e27fe5fcb3f966fa4e249b26a9e23e 100644 (file)
@@ -126,7 +126,7 @@ endif
 endif
 
 $(DL_DIR)/$(PHP_SOURCE):
-        $(call DOWNLOAD,$(PHP_SITE))
+       $(WGET) -P $(DL_DIR) $(PHP_SITE)
 
 php-source: $(DL_DIR)/$(PHP_SOURCE)