ltp-testsuite: change install prefix
authorErico Nunes <nunes.erico@gmail.com>
Sat, 1 Oct 2016 11:50:22 +0000 (13:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Oct 2016 21:22:05 +0000 (23:22 +0200)
ltp-testsuite installs some of its files directly at its specified
prefix, which by default in Buildroot is /usr for autotools packages.
This is currently leaving scripts and its internal directories directly
installed in /usr, such as in:

  # ls /usr
  IDcheck.sh       lib64            runltplite.sh    share
  Version          libexec          runtest          testcases
  bin              runalltests.sh   sbin             testscripts
  lib              runltp           scenario_groups  ver_linux

It also seems to be not feasible to try to install all of its testcases
to standard locations such as /usr/bin as may contain hundreds of
binaries and may not be able to find them all if we change their install
locations. Therefore, it is better if ltp-testsuite installs its tree to
its own self-contained subdirectory.
Upstream instructions recommend that the install path be /opt/ltp,
however it seems that installing things to /opt is not a very common
Buildroot practice.
The proposal then is to install it to /usr/lib/ltp-testsuite and so it
can be run directly from there.

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ltp-testsuite/ltp-testsuite.mk

index cf48072f81e352f819dad4e9f42ec3e9d4e9c4fc..e97659eb0d0fb18786360676f0ddf2fd677fd854 100644 (file)
@@ -21,6 +21,10 @@ else
 LTP_TESTSUITE_CONF_OPTS += --without-modules
 endif
 
+# We change the prefix to a custom one, otherwise we get scripts and
+# directories directly in /usr, such as /usr/runalltests.sh
+LTP_TESTSUITE_CONF_OPTS += --prefix=/usr/lib/ltp-testsuite
+
 # Needs libcap with file attrs which needs attr, so both required
 ifeq ($(BR2_PACKAGE_LIBCAP)$(BR2_PACKAGE_ATTR),yy)
 LTP_TESTSUITE_DEPENDENCIES += libcap