package/lua-msgpack-native: fix build with moonjit
authorFrancois Perrad <fperrad@gmail.com>
Tue, 10 Dec 2019 17:40:04 +0000 (18:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Dec 2019 21:20:10 +0000 (22:20 +0100)
compatibility with Lua 5.0 was removed in LuaJIT/moonjit 2.1.x
(Lua 5.1.x and LuaJIT 2.0.x have this compatibility)

Fixes:

  http://autobuild.buildroot.org/results/4e428df01def186cb034a1774f6c00e2e7c9468c/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: add comment on .mk file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lua-msgpack-native/lua-msgpack-native.mk

index acd3a0e1c95caea747f875244d8a62c47d502452..4a7e672cfa915c07065fbf0b991e32fe13c6ae13 100644 (file)
@@ -10,8 +10,12 @@ LUA_MSGPACK_NATIVE_DEPENDENCIES = luainterpreter
 LUA_MSGPACK_NATIVE_LICENSE = Apache-2.0
 LUA_MSGPACK_NATIVE_LICENSE_FILES = LICENSE.txt
 
+# lua-msgpack-native uses the old Lua 5.0 API with luaL_reg, but it is
+# no longer provided by LuaJit 2.1, so we have to alias luaL_reg to
+# luaL_Reg.
 define LUA_MSGPACK_NATIVE_BUILD_CMDS
-       $(TARGET_CC) $(TARGET_CFLAGS) -fPIC -shared -o $(@D)/msgpack.so $(@D)/mp.c
+       $(TARGET_CC) $(TARGET_CFLAGS) -DluaL_reg=luaL_Reg -fPIC \
+               -shared -o $(@D)/msgpack.so $(@D)/mp.c
 endef
 
 define LUA_MSGPACK_NATIVE_INSTALL_TARGET_CMDS