package/vlc: add optional dependency to libnfs
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:29 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:36:33 +0000 (13:36 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index d34ab2a9e088775beac3374672e148225b0e0ca6..fab08b950d0f7419fb127e2de5f7a3d6e8d8d824 100644 (file)
@@ -71,7 +71,6 @@ VLC_CONF_OPTS += \
        --disable-mmal \
        --disable-mpg123 \
        --disable-mtp \
-       --disable-nfs \
        --disable-notify \
        --disable-projectm \
        --disable-schroedinger \
@@ -311,6 +310,13 @@ else
 VLC_CONF_OPTS += --disable-libmpeg2
 endif
 
+ifeq ($(BR2_PACKAGE_LIBNFS),y)
+VLC_CONF_OPTS += --enable-nfs
+VLC_DEPENDENCIES += libnfs
+else
+VLC_CONF_OPTS += --disable-nfs
+endif
+
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 VLC_CONF_OPTS += --enable-png
 VLC_DEPENDENCIES += libpng