mpd: add option to enable/disable httpd output
authorWaldemar Brodkorb <wbx@openadk.org>
Tue, 19 Jan 2016 22:45:51 +0000 (23:45 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 20 Jan 2016 14:49:49 +0000 (15:49 +0100)
It might be useful to disable this plugin.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 0b3bb72494dbc9f9d8c4792abcb0b04ef83e948d..be0843fb1012a9540efc02daafc3449d0a7872a9 100644 (file)
@@ -223,6 +223,11 @@ config BR2_PACKAGE_MPD_AO
        help
          Enable libao output support.
 
+config BR2_PACKAGE_MPD_HTTPD_OUTPUT
+       bool "httpd output"
+       help
+         Enable httpd output support.
+
 config BR2_PACKAGE_MPD_JACK2
        bool "jack2"
        depends on BR2_ARCH_HAS_ATOMICS
index c794e82817a981b4e3a76eee04aecd31e7e67159..7a265f4875b57bab97164bf4ac06b513478d5200 100644 (file)
@@ -92,6 +92,12 @@ else
 MPD_CONF_OPTS += --disable-flac
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_HTTPD_OUTPUT),y)
+MPD_CONF_OPTS += --enable-httpd-output
+else
+MPD_CONF_OPTS += --disable-httpd-output
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_JACK2),y)
 MPD_DEPENDENCIES += jack2
 MPD_CONF_OPTS += --enable-jack