wireshark: fix static build with libpcap+libusb
authorBaruch Siach <baruch@tkos.co.il>
Sun, 21 Aug 2016 15:06:38 +0000 (18:06 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Aug 2016 20:21:42 +0000 (22:21 +0200)
The wireshark autoconf acinclude.m4 source calls AC_PATH_TOOL() to find
pcap-config only when --with-pcap is missing. Otherwise it just trusts the
PCAP_CONFIG environment variable. Since we use --with-pcap, seeding
ac_cv_path_PCAP_CONFIG gives nothing. Set PCAP_CONFIG instead to let the
configure script discover the dependencies of libpcap. This fixes static build
when libpcap links with libusb.

Fixes:
http://autobuild.buildroot.net/results/ef5/ef50939b89373aad04275cbdeeff4c0e2807c0d5/
http://autobuild.buildroot.net/results/ffc/ffc921135c16c7017cd7a23c5e0c445757509abc/
http://autobuild.buildroot.net/results/2d8/2d8cd47cc664dff0f76a230b36c37291f3087e35/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wireshark/wireshark.mk

index 35f013874ec9e53cd71872388dda8bdeb12f6d9a..baed846b6e5cc9fbfdd1fa1cfebb6ca0d289114b 100644 (file)
@@ -11,7 +11,7 @@ WIRESHARK_LICENSE = wireshark license
 WIRESHARK_LICENSE_FILES = COPYING
 WIRESHARK_DEPENDENCIES = host-pkgconf libpcap libglib2
 WIRESHARK_CONF_ENV = \
-       ac_cv_path_PCAP_CONFIG=$(STAGING_DIR)/usr/bin/pcap-config
+       PCAP_CONFIG=$(STAGING_DIR)/usr/bin/pcap-config
 
 # patch touching configure.ac
 WIRESHARK_AUTORECONF = YES