core/pkg-kconfig: pass host PKG_CONFIG_PATH env var
authorBjørn Forsman <bjorn.forsman@gmail.com>
Fri, 27 May 2016 22:03:28 +0000 (00:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 28 May 2016 17:46:47 +0000 (19:46 +0200)
This is basically the same change as in 0515fe45661b6d320f8d2071df2
("Makefile: pass host PKG_CONFIG_PATH at "make menuconfig" time"). That
commit made sure to pass host PKG_CONFIG_PATH when invoking Buildroot's
own menuconfig program. This change ensures that the same is true for
third party menuconfig programs (i.e. Linux, uClibc and Busybox).

This unbreaks "make {linux,uclibc}-menuconfig" for host platforms which
rely on PKG_CONFIG_PATH to find .pc files (e.g. NixOS). (When Busybox
updates to a more recent Kconfig snapshot, one that uses pkg-config to
find ncurses, "make busybox-menuconfig" will also start working.)

Tested on Ubuntu and NixOS:

  $ make qemu_arm_versatile_defconfig
  $ make linux-menuconfig
  $ make

Signed-off-by: Bjørn Forsman <bjorn.forsman@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-kconfig.mk

index 40d2f881a310f9be7f4babfaa7b88a67b17f5149..b0f51789c39231069c705b51b76aea46add3292b 100644 (file)
@@ -143,7 +143,8 @@ endif
 # nconfig, gconfig, xconfig).
 # So we simply remove our PATH and PKG_CONFIG_* variables.
 $(2)_CONFIGURATOR_MAKE_ENV = \
-       $$(filter-out PATH=% PKG_CONFIG=% PKG_CONFIG_SYSROOT_DIR=% PKG_CONFIG_LIBDIR=%,$$($(2)_MAKE_ENV))
+       $$(filter-out PATH=% PKG_CONFIG=% PKG_CONFIG_SYSROOT_DIR=% PKG_CONFIG_LIBDIR=%,$$($(2)_MAKE_ENV)) \
+       PKG_CONFIG_PATH="$(HOST_PKG_CONFIG_PATH)"
 
 # Configuration editors (menuconfig, ...)
 #