package/libloki: fix build with gcc 11
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Aug 2021 12:13:36 +0000 (14:13 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 1 Aug 2021 18:47:03 +0000 (20:47 +0200)
Fix the following build failure with gcc 11:

In file included from ../include/loki/SmartPtr.h:33,
                 from SmartPtr.cpp:20:
../include/loki/SmallObj.h: At global scope:
../include/loki/SmallObj.h:462:57: error: ISO C++17 does not allow dynamic exception specifications
  462 |         static void * operator new ( std::size_t size ) throw ( std::bad_alloc )
      |

Fixes:
 - http://autobuild.buildroot.org/results/768727160beaca5df3ef18be29cfbaa3ced67ad5

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libloki/libloki.mk

index 7564239f6ac82e76217126b3f3e63c9b1ddfe795..07a9372df9a313089f0dea440f145b28cd2e761e 100644 (file)
@@ -23,6 +23,7 @@ endif
 
 define LIBLOKI_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+               CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11" \
                -C $(@D) $(LIBLOKI_BUILD_TARGETS)
 endef