package/chartjs: move 'v' version prefix out of CHARTJS_VERSION
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 19 Jan 2021 15:46:04 +0000 (16:46 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 19 Jan 2021 17:56:37 +0000 (18:56 +0100)
chartjs 2.9.3 has a security vulnerability (CVE-2020-7746) which is not
detected by the CVE scripts, presumably because our version variable starts
with a 'v'.

Move that 'v' prefix out of the version variable to fix that.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/chartjs/chartjs.hash
package/chartjs/chartjs.mk

index d2426ea614356328ef617e91482abb3db89cdeaa..a029d16ab1b545579c1bbe32e241dc6e8ea93a12 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256 8079d8fd39131fcfaec33f1c7799412bcf8e051e25b10bd6e37fc16159417aa1  chartjs-v2.9.3.tar.gz
+sha256 8079d8fd39131fcfaec33f1c7799412bcf8e051e25b10bd6e37fc16159417aa1  chartjs-2.9.3.tar.gz
 sha256 7b43caae91f31b18dc81fae6e0f7aa1acbecaa6d84e3249905cbe15308307d67  LICENSE.md
index 171e0a4a7c25bb14d85e958972b5ab13df9b982a..960b3e24afcb21d0b4b5eb39d425ac48f07a3551 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-CHARTJS_VERSION = v2.9.3
-CHARTJS_SITE = $(call github,chartjs,Chart.js,$(CHARTJS_VERSION))
+CHARTJS_VERSION = 2.9.3
+CHARTJS_SITE = $(call github,chartjs,Chart.js,v$(CHARTJS_VERSION))
 CHARTJS_LICENSE = MIT
 CHARTJS_LICENSE_FILES = LICENSE.md