jdupre writes in Bug 390: trying to use buildroot failed telling me to install bison...
authorMike Frysinger <vapier@gentoo.org>
Sun, 28 Aug 2005 07:56:08 +0000 (07:56 -0000)
committerMike Frysinger <vapier@gentoo.org>
Sun, 28 Aug 2005 07:56:08 +0000 (07:56 -0000)
toolchain/binutils/binutils.mk

index be8fa0d34ff955d76a57487a08de50971344b073..284a1f722aa043b067d435e35e91d36b47d54700 100644 (file)
@@ -68,6 +68,10 @@ $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ld: $(BINUTILS_DIR1)/binutils/objdump
        $(MAKE) -C $(BINUTILS_DIR1) install
 
 binutils-dependancies:
+       @if ! which which > /dev/null ; then \
+               echo -e "\n\nYou must install 'which' on your build machine\n"; \
+               exit 1; \
+       fi;
        @if ! which bison > /dev/null ; then \
                echo -e "\n\nYou must install 'bison' on your build machine\n"; \
                exit 1; \