util-linux: add option for lsblk
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Feb 2016 20:30:49 +0000 (21:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 26 Feb 2016 18:49:36 +0000 (19:49 +0100)
This commit adds an option to the util-linux package that allows to
build the lsblk utility.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/util-linux/Config.in
package/util-linux/util-linux.mk

index df89f990f8ca20e5587c99ca783675047d686d99..ea2311511b1df8fb2a739669d1afa5e8b8920970 100644 (file)
@@ -134,6 +134,11 @@ config BR2_PACKAGE_UTIL_LINUX_LOSETUP
        help
          Set up and control loop devices
 
+config BR2_PACKAGE_UTIL_LINUX_LSBLK
+       bool "lsblk"
+       help
+         List block devices.
+
 config BR2_PACKAGE_UTIL_LINUX_MESG
        bool "mesg"
        help
index f6e5d629254ae387088d99a6d460fe21ebfcf1c8..cf9505c8de3a16f7409e21fc25274404ff7fbd92 100644 (file)
@@ -84,6 +84,7 @@ UTIL_LINUX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_UTIL_LINUX_LINE),--enable-line,--disable-line) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),--enable-last --enable-login --enable-runuser --enable-su --enable-sulogin,--disable-last --disable-login --disable-runuser --disable-su --disable-sulogin) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_LOSETUP),--enable-losetup,--disable-losetup) \
+       $(if $(BR2_PACKAGE_UTIL_LINUX_LSBLK),--enable-lsblk,--disable-lsblk) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_MESG),--enable-mesg,--disable-mesg) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_MINIX),--enable-minix,--disable-minix) \
        $(if $(BR2_PACKAGE_UTIL_LINUX_MORE),--enable-more,--disable-more) \