linux: remove support of linux26-* targets
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Thu, 24 Jul 2014 17:49:34 +0000 (19:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Jul 2014 21:47:03 +0000 (23:47 +0200)
The linux-* mirror targets of linux26-* have been added a very long time ago
(2010) and linux 2.6 is now considered 'old' anyway. It no longer makes
sense to support these linux26-* targets, so this patch removes them.

This is a simplification introduced in preparation of the kconfig-package
infrastructure.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/initramfs/initramfs.mk
linux/linux.mk

index 5d3ea89f2342d4016ee348599c2d17cc68a15f38..308924d57409a00acf26a4ee91bf888909868221 100644 (file)
@@ -7,7 +7,7 @@
 
 ROOTFS_INITRAMFS_DEPENDENCIES += rootfs-cpio
 
-ROOTFS_INITRAMFS_POST_TARGETS += linux26-rebuild-with-initramfs
+ROOTFS_INITRAMFS_POST_TARGETS += linux-rebuild-with-initramfs
 
 
 # The generic fs infrastructure isn't very useful here.
index a5699f9d7d2f493011035ddf66853a16b23807b4..6c0b272efae6cab56163a650a8cf9c668442c6c8 100644 (file)
@@ -183,7 +183,7 @@ define LINUX_CONFIGURE_CMDS
        # As the kernel gets compiled before root filesystems are
        # built, we create a fake cpio file. It'll be
        # replaced later by the real cpio archive, and the kernel will be
-       # rebuilt using the linux26-rebuild-with-initramfs target.
+       # rebuilt using the linux-rebuild-with-initramfs target.
        $(if $(BR2_TARGET_ROOTFS_INITRAMFS),
                touch $(BINARIES_DIR)/rootfs.cpio
                $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,"$(BINARIES_DIR)/rootfs.cpio",$(@D)/.config)
@@ -312,24 +312,24 @@ include $(sort $(wildcard linux/linux-ext-*.mk))
 $(eval $(generic-package))
 
 ifeq ($(BR2_LINUX_KERNEL),y)
-linux-menuconfig linux-xconfig linux-gconfig linux-nconfig linux26-menuconfig linux26-xconfig linux26-gconfig linux26-nconfig: linux-configure
+linux-menuconfig linux-xconfig linux-gconfig linux-nconfig: linux-configure
        $(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) \
-               $(subst linux-,,$(subst linux26-,,$@))
+               $(subst linux-,,$@)
        rm -f $(LINUX_DIR)/.stamp_{built,target_installed,images_installed}
 
-linux-savedefconfig linux26-savedefconfig: linux-configure
+linux-savedefconfig: linux-configure
        $(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) \
-               $(subst linux-,,$(subst linux26-,,$@))
+               $(subst linux-,,$@)
 
 ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
-linux-update-config linux26-update-config: linux-configure $(LINUX_DIR)/.config
+linux-update-config: linux-configure $(LINUX_DIR)/.config
        cp -f $(LINUX_DIR)/.config $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)
 
-linux-update-defconfig linux26-update-defconfig: linux-savedefconfig
+linux-update-defconfig: linux-savedefconfig
        cp -f $(LINUX_DIR)/defconfig $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)
 else
-linux-update-config linux26-update-config: ;
-linux-update-defconfig linux26-update-defconfig: ;
+linux-update-config: ;
+linux-update-defconfig: ;
 endif
 endif
 
@@ -348,7 +348,7 @@ $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
 
 # The initramfs building code must make sure this target gets called
 # after it generated the initramfs list of files.
-linux-rebuild-with-initramfs linux26-rebuild-with-initramfs: $(LINUX_DIR)/.stamp_initramfs_rebuilt
+linux-rebuild-with-initramfs: $(LINUX_DIR)/.stamp_initramfs_rebuilt
 
 # Checks to give errors that the user can understand
 ifeq ($(filter source,$(MAKECMDGOALS)),)