core/pkg-infra: allow per site-method sub-version strings
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 13 Dec 2020 13:59:28 +0000 (14:59 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 10 Jan 2021 18:42:04 +0000 (19:42 +0100)
When we want to change the format of an archive we generate (e.g. those
we generate from git trees), the hashes of those archives will change.

To avoid any issue (e.g. an older Buildroot using newer archives, or the
other way around) that would conclude that the hashes do not match, we
want to change the filenames of the generated archives whenever we
change their format.

Introduce a new internal variable, specific to each site method, that we
can set to include a "format version" for the archives generated from
that site method.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Vincent Fazio <vfazio@xes-inc.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Vincent Fazio <vfazio@xes-inc.com>
package/pkg-utils.mk

index c7597a3a45d543e740b91c77c6d8b4cb5c519c79..11090cb62837c906000d8b2230257095d3b27d55 100644 (file)
@@ -43,7 +43,7 @@ pkgname = $(lastword $(subst /, ,$(pkgdir)))
 # Helper to build the extension for a package archive, based on various
 # conditions.
 # $(1): upper-case package name
-pkg_source_ext = .tar.gz
+pkg_source_ext = $(BR_FMT_VERSION_$($(1)_SITE_METHOD)).tar.gz
 
 # Define extractors for different archive suffixes
 INFLATE.bz2  = $(BZCAT)